Bug 484114 - VPN disconnect every 5 mins and mouse click does not work
VPN disconnect every 5 mins and mouse click does not work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vpnc (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-04 15:53 EST by Ben
Modified: 2009-02-11 17:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-11 17:18:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben 2009-02-04 15:53:16 EST
Description of problem:
Since I am using Vpn on linux to RDP to my work, the connection keeps dropping every 5 mins. Additionnaly, since the latest update of vpnc (I believe), my mouse clicks do not seems to work on the windows computer I RDP to.

Version-Release number of selected component (if applicable):
vpnc-0.5.3-2.fc10
NetworkManager-vpnc-1:0.7.0-1.svn13.fc10


How reproducible:
Everytime

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

here is the relevent info I got from /var/log/message:

Feb  4 20:08:18 ben NetworkManager: <info>  Starting VPN service 'org.freedesktop.NetworkManager.vpnc'...
Feb  4 20:08:18 ben NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.vpnc' started (org.freedesktop.NetworkManager.vpnc), PID 2933
Feb  4 20:08:19 ben kernel: tun: Universal TUN/TAP device driver, 1.6
Feb  4 20:08:19 ben kernel: tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
Feb  4 20:08:19 ben NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.vpnc' just appeared, activating connections
Feb  4 20:08:19 ben NetworkManager: <info>  VPN plugin state changed: 1
Feb  4 20:08:19 ben NetworkManager: <info>  VPN plugin state changed: 3
Feb  4 20:08:19 ben NetworkManager: <info>  VPN connection 'MyVPN1' (Connect) reply received.
Feb  4 20:08:20 ben kernel: tun0: Disabled Privacy Extensions
Feb  4 20:08:21 ben NetworkManager: <info>  VPN connection 'MyVPN1' (IP Config Get) reply received.
Feb  4 20:08:21 ben NetworkManager: <info>  VPN Gateway: 84.20.193.20
Feb  4 20:08:21 ben NetworkManager: <info>  Tunnel Device: tun0
Feb  4 20:08:21 ben NetworkManager: <info>  Internal IP4 Address: 10.20.193.112
Feb  4 20:08:21 ben NetworkManager: <info>  Internal IP4 Prefix: 24
Feb  4 20:08:21 ben NetworkManager: <info>  Internal IP4 Point-to-Point Address: 10.20.193.112
Feb  4 20:08:21 ben NetworkManager: <info>  Maximum Segment Size (MSS): 0
Feb  4 20:08:21 ben NetworkManager: <info>  Static Route: 10.0.0.0/8   Next Hop: 10.0.0.0
Feb  4 20:08:21 ben NetworkManager: <info>  Static Route: 172.16.0.0/12   Next Hop: 172.16.0.0
Feb  4 20:08:21 ben NetworkManager: <info>  Static Route: 192.168.254.0/24   Next Hop: 192.168.254.0
Feb  4 20:08:21 ben NetworkManager: <info>  Static Route: 192.168.239.0/24   Next Hop: 192.168.239.0
Feb  4 20:08:21 ben NetworkManager: <info>  Static Route: 192.168.1.100/32   Next Hop: 192.168.1.100
Feb  4 20:08:21 ben NetworkManager: <info>  Static Route: 192.168.103.0/24   Next Hop: 192.168.103.0
Feb  4 20:08:21 ben NetworkManager: <info>  Static Route: 192.168.1.150/32   Next Hop: 192.168.1.150
Feb  4 20:08:21 ben NetworkManager: <info>  Static Route: 10.150.0.0/16   Next Hop: 10.150.0.0
Feb  4 20:08:21 ben NetworkManager: <info>  Static Route: 10.50.2.0/29   Next Hop: 10.50.2.0
Feb  4 20:08:21 ben NetworkManager: <info>  Static Route: 10.20.100.53/32   Next Hop: 10.20.100.53
Feb  4 20:08:21 ben NetworkManager: <info>  Static Route: 161.27.202.0/24   Next Hop: 161.27.202.0
Feb  4 20:08:21 ben NetworkManager: <info>  Internal IP4 DNS: 10.2.0.2
Feb  4 20:08:21 ben NetworkManager: <info>  Internal IP4 DNS: 10.2.0.1
Feb  4 20:08:21 ben NetworkManager: <info>  DNS Domain: 'myCompany.com'
Feb  4 20:08:21 ben NetworkManager: <info>  Login Banner:
Feb  4 20:08:21 ben NetworkManager: <info>  -----------------------------------------
Feb  4 20:08:21 ben NetworkManager: <info>  (null)
Feb  4 20:08:21 ben NetworkManager: <info>  -----------------------------------------
Feb  4 20:08:22 ben NetworkManager: <info>  VPN connection 'MyVPN1' (IP Config Get) complete.
Feb  4 20:08:22 ben NetworkManager: <info>  Policy set 'MyVPN1' (tun0) as default for routing and DNS.
Feb  4 20:08:22 ben NetworkManager: <info>  VPN plugin state changed: 4
Feb  4 20:10:45 ben vpnc[2943]: connection terminated by dead peer detection
Feb  4 20:10:45 ben NetworkManager: <info>  VPN plugin state changed: 6
Feb  4 20:10:45 ben NetworkManager: <info>  VPN plugin state change reason: 0
Feb  4 20:10:45 ben NetworkManager: <WARN>  connection_state_changed(): Could not process the request because no VPN connection was active.
Feb  4 20:10:45 ben NetworkManager: nm_system_device_flush_ip4_routes_with_iface: assertion `iface_idx >= 0' failed
Feb  4 20:10:45 ben NetworkManager: nm_system_device_flush_ip4_addresses_with_iface: assertion `iface_idx >= 0' failed
Feb  4 20:10:45 ben avahi-daemon[2113]: Withdrawing address record for 192.168.1.83 on wlan0.
Feb  4 20:10:45 ben avahi-daemon[2113]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 192.168.1.83.
Feb  4 20:10:45 ben avahi-daemon[2113]: Interface wlan0.IPv4 no longer relevant for mDNS.
Feb  4 20:10:45 ben avahi-daemon[2113]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.1.83.
Feb  4 20:10:45 ben avahi-daemon[2113]: New relevant interface wlan0.IPv4 for mDNS.
Feb  4 20:10:45 ben avahi-daemon[2113]: Registering new address record for 192.168.1.83 on wlan0.IPv4.
Feb  4 20:10:46 ben NetworkManager: <info>  Policy set 'Auto BeBox1' (wlan0) as default for routing and DNS.


Please let me know how I should try to debug this. thanks in advance.
Comment 1 Tomas Mraz 2009-02-04 16:06:58 EST
That seems like the DPD is broken for your case. It could be switched off by adding 'DPD idle timeout (our side) 0' to /etc/vpnc/default.conf (If NetworkManager-vpnc does not override the config - I do not know much about NetworkManager-vpnc as I do not use it.)
Comment 2 Ben 2009-02-11 17:18:35 EST
Thanks a lot Tomas,

selecting [x] disable dead peer detection in NetworkManager-vpnc fixed this.

Closing has not a bug. Sorry for the slow response but I thought bugzilla would automaticaly add me in CC, but it did not.

Ben

Note You need to log in before you can comment on or make changes to this bug.