Bug 484118 - block_sizes not used in struct _PedDisk
block_sizes not used in struct _PedDisk
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-04 16:13 EST by David Cantrell
Modified: 2009-06-12 08:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-12 08:49:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Cantrell 2009-02-04 16:13:09 EST
In include/parted/disk.h around line 158 is the definition for the block_sizes member of the _PedDisk structure:

         const int*          block_sizes; /**< block sizes supported
                                               by this label */

This structure member is not used anywhere in libparted.  I would suggest it be removed since having it there is a bit confusing.
Comment 1 Joel Andres Granados 2009-03-26 10:38:46 EDT
I'll take this up with upstream :)
thx for the report.
Comment 2 Bug Zapper 2009-06-09 07:04:13 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Joel Andres Granados 2009-06-12 08:49:03 EDT
I'll include this in new parted version for rawhide so I don't forget to post it to upstream.  This will be available in the next version of parted parted-1.9.0

Note You need to log in before you can comment on or make changes to this bug.