Bug 484121 - Ri-Li crashes with a seg-fault.
Ri-Li crashes with a seg-fault.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Ri-li (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-04 16:35 EST by guitarz1
Modified: 2009-03-02 12:00 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2.13-7.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-12 18:22:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description guitarz1 2009-02-04 16:35:05 EST
Description of problem:
Ri-Li crashes with a seg-fault.  UI displays for a second or so, then closes.  This worked fine in Fedora 8.  I'm using an Nvidia card on an i386 system.  All other OpenGL programs work fine.  I also tested on a Fedora 9 (x86_64) system with Intel Graphics, but there Ri-Li works fine.

Version-Release number of selected component (if applicable):
Base version available in the F9 or F10 repositories.

How reproducible:
Launch Ri-li from the menu, or command-line on an i386 system.  Same results occur.

Steps to Reproduce:
1. Launch Ri-li on an i386.
  
Actual results:
UI displays breifly, then closes (seg-fault).

Expected results:
Hmmm....

Additional info:
Comment 1 guitarz1 2009-02-04 20:24:28 EST
Here's some console output:

[dc@benq ~]$ Ri_li
ALSA lib pulse.c:272:(pulse_connect) PulseAudio: Unable to connect: Connection refused

Segmentation fault
[dc@benq ~]$ su
Password:
[root@benq dc]# Ri_li
ALSA lib pulse.c:272:(pulse_connect) PulseAudio: Unable to connect: Connection refused

Segmentation fault
[root@benq dc]#
Comment 2 guitarz1 2009-02-04 20:28:18 EST
Another error I get sometimes:

[dc@benq ~]$ Ri_li
Enable to init Sound card ! Could not connect to PulseAudio
Segmentation fault
[dc@benq ~]$
Comment 3 guitarz1 2009-02-04 20:29:44 EST
Some system info:

[dc@benq ~]$ uname -a                                   
Linux benq 2.6.27.9-159.fc10.i686 #1 SMP Sat Jan 24 12:05:09 EST 2009 i686 i686 i386 GNU/Linux                                                                      
[dc@benq ~]$ cat /proc/cpuinfo
processor       : 0              
vendor_id       : GenuineIntel   
cpu family      : 6              
model           : 15             
model name      : Intel(R) Pentium(R) Dual  CPU  E2180  @ 2.00GHz
stepping        : 13                                             
cpu MHz         : 1200.000                                       
cache size      : 1024 KB                                        
physical id     : 0                                              
siblings        : 2                                              
core id         : 0                                              
cpu cores       : 2                                              
apicid          : 0                                              
initial apicid  : 0                                              
fdiv_bug        : no                                             
hlt_bug         : no                                             
f00f_bug        : no                                             
coma_bug        : no                                             
fpu             : yes                                            
fpu_exception   : yes                                            
cpuid level     : 10                                             
wp              : yes                                            
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni monitor ds_cpl est tm2 ssse3 cx16 xtpr lahf_lm                     
bogomips        : 3999.90
clflush size    : 64
power management:

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Pentium(R) Dual  CPU  E2180  @ 2.00GHz
stepping        : 13
cpu MHz         : 1200.000
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
apicid          : 1
initial apicid  : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni monitor ds_cpl est tm2 ssse3 cx16 xtpr lahf_lm
bogomips        : 5599.59
clflush size    : 64
power management:

[dc@benq ~]$
Comment 4 guitarz1 2009-02-05 18:04:58 EST
Just to clarify --
  Tested & non-working:
    - Fedora 9 (i386)
    - Fedora 10 (i386)

  Tested & working:
    - Fedora 8 (i386)
    - Fedora 9 (x86_64)
Comment 5 Hans de Goede 2009-02-06 09:14:27 EST
This is really strange I've managed to reproduce it, and track down the line of code causing it, but that line of code is fine. I have no clue what is happening here. I've filed a bug against gcc for now, but that may be a dead end (as I',m not sure gcc is the one to blaim).

See bug 484362.
Comment 6 Hans de Goede 2009-02-12 18:22:05 EST
Ok, I've got confirmation this is definitely an SDL bug, closing this as a dup of the one tracking that. I hope to be able to do an SDL update fixing this soon.

*** This bug has been marked as a duplicate of bug 484362 ***
Comment 7 guitarz1 2009-02-15 19:32:12 EST
I've download the SDL update from the updates-testing repository.  I installed SDL-1.2.13-7, and it fixes the issue with Ri-li.

Thanks to all involved!!
Comment 8 Fedora Update System 2009-03-02 12:00:10 EST
SDL-1.2.13-7.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.