Bug 484126 - mpitests package doesn't have requires for the libraries it's testing..
mpitests package doesn't have requires for the libraries it's testing..
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openmpi (Show other bugs)
4.8
All Linux
low Severity low
: alpha
: ---
Assigned To: Doug Ledford
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-04 17:17 EST by Gurhan Ozen
Modified: 2013-11-03 20:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 07:02:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1519 normal SHIPPED_LIVE mpitests bug fix update 2009-10-21 07:02:34 EDT

  None (edit)
Description Gurhan Ozen 2009-02-04 17:17:19 EST
Description of problem:
There was no mpitests component in BZ, so i am opening this under openmpi. mpitests-mvapich2 package correctly has dependency for mvapich2 where has mpitests-openmpi and mpitests-mvapich don't:

# rpm -qa | grep mpitests-
mpitests-mvapich2-3.1-1.el4
mpitests-openmpi-3.1-1.el4
mpitests-mvapich-3.1-1.el4
# rpm -e mvapich.x86_64
error: Failed dependencies:
	libmpich.so.1.0()(64bit) is needed by (installed) mpitests-mvapich-3.1-1.el4.x86_64

# rpm -e mvapich2.x86_64
# rpm -e openmpi
#

Version-Release number of selected component (if applicable):
# rpm -qa | grep mpitests-
mpitests-mvapich2-3.1-1.el4
mpitests-openmpi-3.1-1.el4
mpitests-mvapich-3.1-1.el4


How reproducible:
Very
Comment 1 Tru Huynh 2009-07-06 14:26:57 EDT
not only that, mpitests (mpitests-3.1-1.el4.src.rpm) can't be built with the released mvapich/mvapich2 (mvapich-1.1.0-0.3143.4.el4/mvapich2-1.2-0.p1.4.el)
due to incorrect MPI_BIN and MPI_LIB (version-gcc instead of version-gcc4)

[tru@sillage SPECS]$ grep ^MPI_BIN mpitests.spec
MPI_BIN=%{_libdir}/openmpi/$VERSION-gcc/bin
MPI_BIN=%{_libdir}/mvapich/$VERSION-gcc/bin
MPI_BIN=%{_libdir}/mvapich2/$VERSION-gcc/bin

[tru@sillage RPMS]$ rpm -qlp mvapich* | grep mpicc$
/usr/lib/mvapich/1.1.0-gcc4/bin/mpicc
/usr/lib/mvapich2/1.2-gcc4/bin/mpicc
[tru@sillage RPMS]$ md5sum mvapich*
69e69e3990eec2a3b28e4784b77fc996  mvapich-1.1.0-0.3143.4.el4.i386.rpm
2bbb9a547de9a69189cd6ab6f73302ff  mvapich2-1.2-0.p1.4.el4.i386.rpm
[tru@sillage2 RPMS]$ rpm -K mvapich*
mvapich-1.1.0-0.3143.4.el4.i386.rpm: (sha1) dsa sha1 md5 gpg OK
mvapich2-1.2-0.p1.4.el4.i386.rpm: (sha1) dsa sha1 md5 gpg OK
Comment 2 Doug Ledford 2009-08-24 09:40:51 EDT
Note: This bug is against openmpi, but that's only because mpitests does not have a bugzilla component.  The real issue is with the mpitests package.
Comment 6 errata-xmlrpc 2009-10-21 07:02:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1519.html

Note You need to log in before you can comment on or make changes to this bug.