Bug 484260 - mkinitrd does not include cciss driver on fresh F11-alpha install
mkinitrd does not include cciss driver on fresh F11-alpha install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-05 13:04 EST by Doug Chapman
Modified: 2009-02-05 21:26 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-05 21:26:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log from the failed install (24.26 KB, text/plain)
2009-02-05 13:04 EST, Doug Chapman
no flags Details

  None (edit)
Description Doug Chapman 2009-02-05 13:04:42 EST
Created attachment 331041 [details]
anaconda.log from the failed install

Description of problem:
I did an install of F11-alpha on an HP DL380 with storage on a Smart Array (aka cciss).  The first reboot failed to find the root filesystem.  Booting rescue mode does show that the install worked properly however the new initrd.img did not include the cciss driver.


Version-Release number of selected component (if applicable):
mkinitrd-6.0.75-1.fc11.x86_64

How reproducible:


Steps to Reproduce:
1. Install to cciss disk
2. try to boot
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2009-02-05 13:49:46 EST
I don't know if this is useful or not but here is the smolt profile for this system.

http://www.smolts.org/client/show/?uuid=pub_5fc86b86-253a-45c5-b322-03f574c5651e
Comment 2 Doug Chapman 2009-02-05 14:50:40 EST
FYI, as I dig deeper this is looking like an LVM bug (or at least the bug is due to a change in behavior or LVM).  I will keep digging on this.  I am re-installing F10 on this system to see how it handled it so I know exactly what changed.
Comment 3 Doug Chapman 2009-02-05 21:26:40 EST
Appears this is fixed in mkinitrd-6.0.76-1.fc11

Note You need to log in before you can comment on or make changes to this bug.