Bug 484271 - [LTC 6.0 FEAT] 201642: Include IB bonding feature from OFED recent release
[LTC 6.0 FEAT] 201642: Include IB bonding feature from OFED recent release
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
other All
low Severity high
: rc
: 6.0
Assigned To: Doug Ledford
Gurhan Ozen
: FutureFeature
Depends On:
Blocks: 356741 554559
  Show dependency treegraph
 
Reported: 2009-02-05 14:40 EST by IBM Bug Proxy
Modified: 2013-11-03 20:42 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 11:10:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 51449 None None None Never

  None (edit)
Description IBM Bug Proxy 2009-02-05 14:40:28 EST
=Comment: #0=================================================
Pradeep Satyanarayana <pradeep@us.ibm.com> - 
1. Feature Overview:
Feature Id:	[201642]
a. Name of Feature:	 Include IB bonding feature from OFED recent release
b. Feature Description
This features include InfiniBand bonding from OFED 1.4 or later
2. Feature Details:
Sponsor:	Linux Systems Tech
Architectures:
x86
x86_64
ppc64

Arch Specificity: Both
Affects Kernel Modules: Yes
Delivery Mechanism: Direct from community
Category:	Networking
Request Type:	Package - Feature from Upstream
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	3rd party code
g. Component Version Target:	

3. Business Case
IBM middle ware (HPC, GPFS, DB2 etc.) ability to use "failover mechanisms" on IB interconnects

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Mike Wortman, wortman@us.ibm.com, 512-838-8582

Technical contact(s):
Pradeep Satyanarayana, pradeep@us.ibm.com

IBM Manager:
Larry Kessler, lkessler@us.ibm.com
Comment 1 Doug Ledford 2010-01-28 12:09:32 EST
IB bonding is enabled in the 2.6.32 kernels.  However, we do *not* use an ib-bonding package like OFED does.  OFED does that merely to deliver a modified core bonding module for kernels that don't already support IB bonding.  Since we do, that package is not necessary.  Setting up ib bonding is done the same is it is done for ethernet interfaces, via the /etc/sysconfig/network-scripts/ifcfg-ib? files.  Only failover mode bonding is support, this is a limitation of the IB hardware.
Comment 2 IBM Bug Proxy 2010-02-01 08:51:23 EST
------- Comment From sglass@us.ibm.com 2010-02-01 08:42 EDT-------
Since this is in RH cvs tree, moving to Accepted state
Comment 3 IBM Bug Proxy 2010-05-17 17:21:21 EDT
------- Comment From halves@linux.vnet.ibm.com 2010-05-17 17:16 EDT-------
Hello,

IB Bonding worked on RHEL6 snap3.

Regards,

Higor
Comment 4 releng-rhel@redhat.com 2010-11-11 11:10:47 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.