Bug 484276 - serious screen corruption installing f11 alpha
serious screen corruption installing f11 alpha
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-05 15:18 EST by David
Modified: 2014-01-21 01:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-27 14:35:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
working Xorg.0.log (using vesa driver) (33.28 KB, text/plain)
2009-02-06 08:09 EST, David
no flags Details
working xorg.conf (2.15 KB, text/plain)
2009-02-06 08:24 EST, David
no flags Details
Xorg.0.log wit no xorg.conf (40.01 KB, text/plain)
2009-02-09 10:39 EST, David
no flags Details
Xorg.0.log using Xorg -configure xorg.conf (36.71 KB, text/plain)
2009-02-09 10:57 EST, David
no flags Details

  None (edit)
Description David 2009-02-05 15:18:36 EST
Description of problem:


Version-Release number of selected component (if applicable):
Whatever comes with f11 alpha

How reproducible:
Every time

Steps to Reproduce:
1. Attempt a hard drive installation of f11 alpha
2.
3.
  
Actual results:
only about 30% of monitor area is used once anaconda starts
Buttons and pulldowns are badly corrupted
Computer hung after only a few screens (may be unrelated to the graphics problem)

Expected results:
full screen, non corrupted graphical installation without hanging

Additional info:
f10 smolt profile
http://www.smolts.org/client/show/pub_f24c96f9-7884-4d14-a298-63a2847d0c0e
(note... there is significant screen corruption in f10 as well, but not as bad as f11 alpha anaconda)
Comment 1 seth vidal 2009-02-05 15:30:41 EST
I had a similar hang right before the end of the copy-to-disk install of the livecd under a kvm instance with 1GB of memory allocated to it.
Comment 2 Brock Organ 2009-02-05 15:31:43 EST
> Computer hung after only a few screens (may be unrelated to the graphics
> problem)

I'm seeing this behavior (without the screen corruption described above) as
well shortly after package installation starts.  (It usually hangs during
installation of one of the first 50 packages ...)

I'm booting from the F11-alpha i386 CDROM 1 iso image ...
Comment 3 David 2009-02-05 16:21:45 EST
I've started a text installation, and that is going more smoothly so far (about 50% of packages installed right now).  So I still suspect that my particular hang is graphics related.  I'll report more if/when the text installation completes.
Comment 4 David 2009-02-05 17:35:49 EST
I've successfully done a text mode installation, but the system hung
after startx.  I got a bug buddy window with some corruption (I don't
know what crashed) after X started and then nothing for several minutes.
The mouse moved a corrupt little fedora wait icon around the screen,
but there were no other signs of life.  I didn't check if I could ping or
ssh into it.  I couldn't ctrl-alt-del to reboot and ctrl-alt-backspace didn't
work (although I think I saw in the release notes that it doesn't do
anything by default anymore).  In the end, I power cycled and booted
back to the f10 partition (where there is still X corruption but no
hangs).  I'm pretty sure the f11 hangs are graphics driver related
due to the track record of intel driver on my hardware.

The other people who had hangs with different graphics chips and without
the screen corruption might want to open separate bugs since they may
be unrelated.
Comment 5 David 2009-02-05 17:58:43 EST
I ran Xorg -configure and then copied the resulting xorg.conf to /etc/X11 and then edited it to change the driver to vesa, and X is working fine so far.
Comment 6 Matěj Cepl 2009-02-06 07:37:32 EST
(In reply to comment #5)
> I ran Xorg -configure and then copied the resulting xorg.conf to /etc/X11 and
> then edited it to change the driver to vesa, and X is working fine so far.

Could we get /var/log/xorg.conf and /var/log/Xorg.0.log in the working and non-working situation, please?

Thank you
Comment 7 David 2009-02-06 08:09:02 EST
Created attachment 331124 [details]
working Xorg.0.log (using vesa driver)

I can't get the not-working Xorg.0.log until Monday, sorry.
Comment 8 David 2009-02-06 08:24:26 EST
Created attachment 331126 [details]
working xorg.conf

The non-working xorg.conf was no xorg.conf.  I don't think I tried the xorg.conf created with Xorg -configure without changing the driver to vesa.  I can do that on Monday if you'd like.
Comment 9 Matěj Cepl 2009-02-08 10:52:27 EST
(In reply to comment #8)
> The non-working xorg.conf was no xorg.conf.  I don't think I tried the
> xorg.conf created with Xorg -configure without changing the driver to vesa.  I
> can do that on Monday if you'd like.

yes, please
Comment 10 David 2009-02-09 10:39:59 EST
Created attachment 331324 [details]
Xorg.0.log wit no xorg.conf
Comment 11 David 2009-02-09 10:57:15 EST
Created attachment 331327 [details]
Xorg.0.log using Xorg -configure xorg.conf

the xorg.conf used was identical to the previously attached working xorg.conf except the default "intel" driver was used instead of changing to "vesa".  With this xorg.conf and with no xorg.conf, there is corruption and a hang.  The keyboard is unresponsive, but the mouse moves around the corrupt screen, but mouse clicks do nothing.
Comment 12 Matěj Cepl 2009-02-10 13:09:23 EST
Hmm, I don't see any crash there. Reassigning.
Comment 13 David 2009-02-10 13:28:22 EST
There was screen corruption and a hang, not a crash.  The same system has screen corruption in f10 with the intel driver but does not hang.  In both f10 and f11, the vesa driver works without hanging and without corruption.
Comment 14 David 2009-03-24 17:08:21 EDT
X is still hanging for me.  I didn't notice the corruption anymore.
I am now have this installed:

xorg-x11-drv-intel.i586 2.6.0-14.fc11 

I also don't see a mouse pointer when I start with the intel driver.
vesa still works fine.
Comment 15 David 2009-03-24 17:15:10 EDT
I forgot to mention... even text mode is now screwed up
on this system.  Some text is off the left of the screen
during boot.  It starts out fine, but then it switches modes
to smaller font and about 5-10 characters are hidden off
the left side of the screen.  I realize this isn't related
to the xorg driver, but I thought it might still be important
to mention as it may relate to how the graphics is initialized.
If you want me to file a separate bug for that one, what is 
the appropriate component to file it against?
Comment 16 David 2009-04-06 18:26:16 EDT
Is more information required on this bug?  It's been two
months since I submitted this report and it is still
hanging in rawhide.
Comment 17 Bug Zapper 2009-06-09 07:05:17 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 18 Vedran Miletić 2009-09-06 03:27:15 EDT
In Fedora 11 package is named xorg-x11-drv-intel. Changing bugs apropriately.
Comment 19 Matěj Cepl 2009-11-05 13:21:48 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 20 Matěj Cepl 2010-02-26 07:25:26 EST
Could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[Note please, that this is machine generated comment for large amount of bugs; due to some technical issues, it is possible we've missed some of the responses -- it is happens, please, just a make a comment about that; that we will see. Thank you]
Comment 21 David 2010-03-01 11:34:28 EST
I had too many problems with the intel driver and had to replace that machine.
I can drop that old machine off at Redhat's Mountain View California office
for a month or two if it would help you improve the Intel drivers.  Let me
know if you want me to do that.
Comment 22 Bug Zapper 2010-04-27 08:52:26 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 23 Adam Jackson 2010-04-27 14:35:04 EDT
All known screen corruption issues on 865 should be resolved in F13.

Note You need to log in before you can comment on or make changes to this bug.