Bug 484282 - Migrate SSM channel subscription updates to be asynchronous
Migrate SSM channel subscription updates to be asynchronous
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
high Severity medium
: ---
: ---
Assigned To: Jay Dobies
John Matthews
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-02-05 15:56 EST by Jay Dobies
Modified: 2009-09-10 16:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:32:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Dobies 2009-02-05 15:56:17 EST
After implementing the backend for asynchronous SSM operations (BZ 483606), we need to migrate the driving use case over to use it. This BZ is to track moving the channel subscription updates to use the asynchronous system.
Comment 1 Jay Dobies 2009-02-09 16:44:29 EST
Commit: 1c2c0a83d18b90e95d1ab0d7b14c34bd9c83593f

Migrated to use message queue and asynchronous operation logging.
Comment 2 John Matthews 2009-05-05 16:29:10 EDT
Verified ISO: Satellite-5.3.0-RHEL4-re20090501.1-i386-embedded-oracle.iso
Comment 3 Jay Dobies 2009-08-14 11:44:09 EDT
Test Plan:

Set up a system subscribed to base channel with at least one child channel. Don't subscribe the system to that child.

1. Select the system into the SSM.
2. Enter the SSM page using the "Manage" link in the top right
3. Select "Manage systems' channel memberships"
4. Select "Subscribe" for the child channel and press "Alter Subscription".
5. Select "Change Subscriptions" on the next page.

You'll be dropped to the SSM Status page (/rhn/ssm/ViewAllLog.do). There should be an entry corresponding to the channel changes selected in step 4. If it's not there, refresh the page (sometimes the page appears before the actual subscribe operation has been pulled off the message queue).

If the operation still reflects as in progress, wait a short bit and refresh again. Since there are so few servers the operation should move to Completed almost instantaneously.

Click the link to the status row on that page to make sure the correct servers are listed.
Comment 4 Brandon Perkins 2009-09-10 16:32:43 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.