Bug 484291 - Garbage on screen and X crash on F11 Alpha live
Garbage on screen and X crash on F11 Alpha live
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-05 16:36 EST by Cosimo Cecchi
Modified: 2013-04-30 18:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-16 18:59:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
could not switch to ttys, ctrl-alt-del didn't work, Fedora 11 Alpha Xorg.0.log from i845 video chipset with no xorg.conf (20.21 KB, text/plain)
2009-02-15 09:56 EST, Antal KICSI
no flags Details
Xorg.0.log on i845 video, Fedora 11 Alpha (20.21 KB, text/plain)
2009-02-15 09:59 EST, Antal KICSI
no flags Details
Xorg.0.log with Fedora11 Beta LiveCD on i845 video (50.16 KB, application/octet-stream)
2009-03-31 14:08 EDT, Antal KICSI
no flags Details
Xorg.0.log with Fedora11 Beta LiveCD on i845 video with "nomodeset" boot parameter (59.88 KB, application/octet-stream)
2009-03-31 14:12 EDT, Antal KICSI
no flags Details

  None (edit)
Description Cosimo Cecchi 2009-02-05 16:36:54 EST
When starting the Fedora 11 Alpha live CD:

- gdm is spawned
- I can see the animated cursor
- instead of seeing the gdm background, green/orange/brown garbage rectangles are drawn on the screen for ~2 seconds
- X crashes
- gdm is spawned again, garbage keeps being drawn and X keeps crashing

Platform:
- Dell Inspiron 630m laptop
- Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03) (as reported by lspci).

Works fine in F10.
Comment 1 Matěj Cepl 2009-02-06 07:41:11 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 kivar 2009-02-08 12:43:57 EST
I'm still getting the same types of crashes with the fedora 11 live cd that I got with the fedora 10 live cd's on my machine with the intel 845 intergrated graphics.

Whatever the problem is/was with the fedora 10 Intel 845 Xorg chipset drivers, it still haven't been solved,since it's cropping up in the fedora 11 alpha live cd.
Comment 3 Matěj Cepl 2009-02-08 13:27:58 EST
Yes, and could we get the information requested in comment 1, please?

Thank you
Comment 4 Cosimo Cecchi 2009-02-08 15:20:11 EST
(In reply to comment #1)

> Please attach your X server config file (/etc/X11/xorg.conf, if available) and
> X server log file (/var/log/Xorg.*.log) to the bug report as individual
> uncompressed file attachments using the bugzilla file attachment link below.
> 
> Could you please also try to run without any /etc/X11/xorg.conf (if you have
> one) whatsoever and let X11 autodetect your display and video card? Attach to
> this bug /var/log/Xorg.0.log from this attempt as well, please.

My /etc/X11/xorg.conf file is whatever is used by default in the F11 Alpha i686 live CD.
I'm not sure on how I can give you the Xorg.0.log file, given that X crashes as soon as gdm is spawned. Then, X is restarted and gdm is spawned again and again, and it never seem to drop me to a shell after the crash.
Comment 5 Matěj Cepl 2009-02-08 17:32:54 EST
(In reply to comment #4)
> I'm not sure on how I can give you the Xorg.0.log file, given that X crashes as
> soon as gdm is spawned. Then, X is restarted and gdm is spawned again and
> again, and it never seem to drop me to a shell after the crash.

You can start in runlevel 3 (just before the computer boots press any key and get into grub menu, there press 'a' and fix the kernel command line so that there are no words "rhgb" and "quiet", but it ends with number 3. That should land you in the text-only mode, where you can log as root and copy /var/log/Xorg.*.log and /var/log/anaconda.xlog files (whichever you have) somewhere else (USB keychain?).

Also you can add xdriver=vesa to the kernel command line to get (hopefully) more safe (although slow) option how to run X server.

Does it help?
Comment 6 Antal KICSI 2009-02-15 09:56:46 EST
Created attachment 331972 [details]
could not switch to ttys, ctrl-alt-del didn't work,
Fedora 11 Alpha Xorg.0.log from i845 video chipset with no xorg.conf
Comment 7 Antal KICSI 2009-02-15 09:59:51 EST
Created attachment 331973 [details]
Xorg.0.log on i845 video, Fedora 11 Alpha

Sorry about the previous post - I get confused 

I have a Fujitsu-Siemens ScenicS2 with the i845 video chipset.  If I boot  the Fedora11 Alpha LiveCD I get the automatic login screen - after login I have a moving mouse pointer on the Solar background and nothing else happening. The machine is frozen - could not switch to ttys, ctrl-alt-del didn't work,
ctrl-alt-backspace didn't work either. I need to shut down from the power button.
I did not try to ssh in.

I tested the LiveCD's also on an IBM NetVista 8313 and a Compaq Evo D510 with
the same results. (Both have the i845 video chipset)

In the attachments I have provided, the Xorg.0.log was when I had no xorg.conf

I have the same problem with Fedora 10.The error seems to be related to the acceleration method used in thexorg-x11-i810 driver (the default now is EXA before was XAA). 
In Fedora 10 there is a workaround: by generating an xorg.conf and changing the accel method to xaa the driver works. 
However in Fedora 11 Alpha this workaround does not work.

All the above mentioned computers are working fine with Fedora 8 and 9.
Comment 8 Matěj Cepl 2009-02-16 11:49:58 EST
Lovely! (the end of log):

(II) intel(0): [DRI] installation complete
(II) intel(0): xf86BindGARTMemory: bind key 0 at 0x07fff000 (pgoffset 32767)
(EE) intel(0): Failed to pin front buffer: Cannot allocate memory

Fatal server error:
Couldn't bind memory for BO front buffer
Comment 9 Antal KICSI 2009-02-21 10:48:20 EST
By the way - I see at Fedora Release Criteria the following guideline: The installed system MUST boot and start up properly . I think it is not too mutch to ask then the installed system at least SHOULD boot and start up properly. Unfortunately these are not true for me from Fedora 10 on intel 845 video chipset.
I hope there will be a solution for Fedora 11. Thanks in advance!
Comment 10 Antal KICSI 2009-03-31 14:08:28 EDT
Created attachment 337368 [details]
Xorg.0.log with Fedora11 Beta LiveCD on i845 video

The Fedora11 Beta Live CD does not work as expected on my hardware (Fujitsu-Siemens ScenicS2 with i845 integrated video ): boots, almost everything works exept no mouse cursor.  It detects motion, but the cursor is invisible.I can guess where the cursor is and click in windows.This is the same behaviour as with the 2009-03-12 intel Test Days Live CD.
I attached the Xorg.0.log for this case.

Adding "nomodeset" to the boot command line resulted in a running Xserver with
mouse cursor.
Comment 11 Antal KICSI 2009-03-31 14:12:35 EDT
Created attachment 337370 [details]
Xorg.0.log with Fedora11 Beta LiveCD on i845 video with "nomodeset" boot parameter

Attached the Xorg.0.log when I started the Fedora11 Beta LiveCD with "nomodeset" boot parameter - running Xserver with mouse cursor on the same i845 video hardware!
Comment 12 Cosimo Cecchi 2009-04-01 08:18:25 EDT
I guess that's a different bug.
Now, with the F11 Beta Live CD, I don't get the crash anymore on my laptop (i915), and X is working as expected. Should we close this report and open another one for the issue reported by kicsia?
Comment 13 Adam Williamson 2009-04-16 18:59:59 EDT
Yes. The issue Cosimo initially reported, and the similar issues reported by kicsia in alpha and snapshots, are fixed by both reporter's accounts. The remaining issue - missing cursor on i8xx chipset with KMS enabled - is unrelated, known, and has its own separate report. So, closing this report. Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.