Bug 484307 - parted needs a flag to indicate LUKS partitions
parted needs a flag to indicate LUKS partitions
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-05 18:19 EST by David Lehman
Modified: 2009-06-12 09:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-12 09:03:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2009-02-05 18:19:03 EST
Description of problem:
This is mostly geared toward libparted.

Parted appears to be trying to get away from the hex partition type codes, using instead flags for swap, lvm, and mdraid. It seems like there should also be a flag to indicate partitions whose contents are encrypted using LUKS/dm-crypt.

Version-Release number of selected component (if applicable):
parted-1.8.8-12.fc11

How reproducible:
Always

Steps to Reproduce:
1. create a partition and encrypt is w/ LUKS
2. try to use parted to identify it's usage
3.
  
Actual results:
libparted does not indicate that the partition is encrypted.

Expected results:
libparted sets a flag to indicate the partition is encrypted

Additional info:
This came up while I was thinking about partition clearing in anaconda. Currently, we can look at the numeric partition type codes, but the new pyparted does not seem to export this information. I was told that this is because libparted does not want people using these codes if possible.
Comment 1 Jeremy Katz 2009-02-05 23:16:00 EST
Honestly, we should probably move away from using parted for any of this sort of stuff unless we get parted to use libblkid to do the identification.  Otherwise, there are way too many weird heuristic cases that we end up having to fix in both places due to utils not doing a good job of clobbering other fs signatures.
Comment 2 David Lehman 2009-02-05 23:21:06 EST
Ok, but FWIW I am not using libblkid at all in the new storage code. I'm using the information provided by udev.
Comment 3 Jeremy Katz 2009-02-06 09:22:25 EST
udev uses /lib/udev/vol_id which uses libblkid :)
Comment 4 David Lehman 2009-02-06 11:55:45 EST
vol_id doesn't use libblkid AFAICT
Comment 5 Bug Zapper 2009-06-09 07:05:29 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Joel Andres Granados 2009-06-12 09:03:51 EDT
closing per comment 1.  I know I initially agreed to do this but I think its too much of a hassle to create a flag that wont be correctly used anyway (I'm judging by the use of other flags like boot and FS specific flags that arent set or unset by the tools that handle FSs)

Note You need to log in before you can comment on or make changes to this bug.