Bug 484312 - Virt type options need fixing
Virt type options need fixing
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Virtualization (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Mike McCune
Steve Salevan
:
: 485220 (view as bug list)
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-02-05 19:21 EST by Mike McCune
Modified: 2009-09-10 15:24 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:24:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2009-02-05 19:21:05 EST
* We need to filter out KVM if the product is Satellite.  RHEL doesn't support KVM yet.  The only options we should present in Satellite for virt types are:

- Para-Virtualized Host
- XEN Para-Virtualized Guest

We don't need the None option anymore because it really served no real function other than forcing users to create separate kickstarts for their PV guests and their standard machines.  

* if user selects Para-Virtualized Host you get an ISE

This profile type is 'special' in that we add the xen and kernel-xen to the %packages stanza if you select this option.  It makes it easier for users to create RHEL5 Host machines.

When syncing to cobbler we should just translate this para_host to 'xenpv' into the cobbler profile.

* we need to upgrade all existing 'none' types to xenpv

* fix queries that filter out profile types based on virt type.  When kickstarting a virtual guest we should show every profile except ones with a type 'auto'
Comment 1 Mike McCune 2009-02-12 22:46:53 EST
*** Bug 485220 has been marked as a duplicate of this bug. ***
Comment 2 Steve Salevan 2009-02-24 12:43:50 EST
All above fixes are applied in 530-re20090220.1.  Moving to VERIFIED.
Comment 3 Jan Hutař 2009-09-01 05:26:13 EDT
Hello,
I have some questions in point 1 and 3:

(In reply to comment #0)
> * We need to filter out...

When creating/editing KS, I see 5 options in the "Virtualization Type:":
 * None
 * KVM Virtualized Guest
 * Xen Virtualized Host
 * Xen Para-Virtualized Guest
 * Xen Full-Virtualized Guest
and that seems perfectly OK to me -> I do not understand to this point. Is what I see correct?

> * if user selects Para-Virtualized Host you get an ISE

I was able to create Xen PV Guest KS and provision guest from the Satellite.

> * we need to upgrade all existing 'none' types to xenpv

I do not agree and I still see "None" in the list, but as this BZ was already verified, I'm confused. So again: is what I see correct?

> * fix queries that filter out profile types based on virt type.  When
> kickstarting a virtual guest we should show every profile except ones with a
> type 'auto'  

When I'm provisioning Xen virt guest (system -> Virtualization -> Provisioning), I see only guest KS profiles (and KS profiles not managed by Satellite). But when I'm kickstarting bare metal system (system -> Provisioning -> Kickstart -> Schedule), Xen PV Guests are correctly filtered out of the list.

Regards,
Jan
Comment 4 Mike McCune 2009-09-03 16:10:05 EDT
1) Yes, what you see is correct.

2) good

3) What you see is correct, so we can close this out

4) The filtering sounds correct.

All sounds well.
Comment 5 Jan Hutař 2009-09-04 04:55:58 EDT
Thank you.
Comment 6 Brandon Perkins 2009-09-10 15:24:15 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.