Bug 484326 - app doesn't start: problem with default OpenGL driver(?)
app doesn't start: problem with default OpenGL driver(?)
Status: CLOSED DUPLICATE of bug 476875
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-05 22:24 EST by L
Modified: 2009-02-08 06:26 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-07 09:41:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description L 2009-02-05 22:24:37 EST
Description of problem:
Program doesn't start, reports an error related to my graphics card.  Fresh install of Fedora 10, default video driver.



Version-Release number of selected component (if applicable):
$ rpm -q avogadro
avogadro-0.8.1-6.fc10.i386

$ uname -a
Linux xx.xx.xx.xx 2.6.27.12-170.2.5.fc10.i686 #1 SMP Wed Jan 21 02:09:37 EST 2009 i686 i686 i386 GNU/Linux



How reproducible:
very


What I expect:
an error message or report.  Incompatible drivers?  Improper 3D support for OpenGL? 

  

Actual results:

-from menu:
Applications > Education > Avogadro  (no response, no error)

-from terminal
$ avogadro
System has OpenGL support.
Locale:  "en_US" 
Loaded translations (if needed) about to test OpenGL capabilities.
OpenGL capabilities found: 
	Double Buffering.
	Direct Rendering.
	Antialiasing.

Found Tool:  "Align"  -  "Align molecules" 
Found Tool:  "AutoOptimization"  -  "Automatic Optimization Tool" 
Found Tool:  "AutoRotate"  -  "Auto Rotation Tool" 
Found Tool:  "Bond Centric Manipulate"  -  "Bond Centric Manipulation Tool" 
Found Tool:  "Measure"  -  "Click to Measure Tool" 
Found Tool:  "Draw"  -  "Draws Things" 
Found Tool:  "Manipulate"  -  "Manipulation Tool" 
Found Tool:  "Navigate"  -  "Navigation Tool" 
Found Tool:  "Select/Rotate"  -  "Selection and Rotation Tool" 
avogadro: radeon_lock.c:100: radeonGetLock: Assertion `drawable != ((void *)0)' failed.
Aborted



Additional info:

$ lspci -v
...
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AT [FireGL T2] (rev 80) (prog-if 00 [VGA controller])
	Subsystem: ATI Technologies Inc Device 0002
	Flags: bus master, 66MHz, medium devsel, latency 66, IRQ 20
	Memory at f0000000 (32-bit, prefetchable) [size=128M]
	I/O ports at 2000 [size=256]
	Memory at f8500000 (32-bit, non-prefetchable) [size=64K]
	[virtual] Expansion ROM at f8000000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel modules: radeon, radeonfb
...



==>  It seems related to OpenGL but I am ignorant about which graphics driver is being used by default.  (please give instructions)  In case it is helpful for the package developer, I will wait before following instructions at fedorafaq.org for installing ATI's flgrx.  For Avogadro to be included as a stable package, I think it should work with the default drivers or at least provide a warning error.

If there is no response by about 1 week, I will install fglrx and come back here with a comment.
Comment 1 Rex Dieter 2009-02-06 09:31:48 EST
avogadro: radeon_lock.c:100: radeonGetLock: Assertion `drawable != ((void *)0)'
failed.

Isn't coming form avogadro, but (likely) your X driver itself, reassigning -> xorg-x11-drv-ati
Comment 2 François Cami 2009-02-07 09:41:45 EST
Thank you for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

Closing as duplicate of 475952 .

*** This bug has been marked as a duplicate of bug 475952 ***
Comment 3 François Cami 2009-02-08 06:26:09 EST
475952 is against rawhide, while 476875 is against F10.

*** This bug has been marked as a duplicate of bug 476875 ***

Note You need to log in before you can comment on or make changes to this bug.