Bug 484357 - Applications using PolicyKit-gnome PolKitGnomeToggleAction widgets do not work
Applications using PolicyKit-gnome PolKitGnomeToggleAction widgets do not work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PolicyKit-gnome (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-06 08:33 EST by Richard Hughes
Modified: 2009-02-13 01:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 01:56:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Hughes 2009-02-06 08:33:32 EST
Description of problem:

Applications using PolicyKit-gnome PolKitGnomeToggleAction widgets do not work -- you can press the buttons and nothing happens. Other PolKitGnone widgets seem to work well.

Version-Release number of selected component (if applicable):

PolicyKit-gnome-0.9-3.fc10.i386

How reproducible:

Always

Steps to Reproduce:
1. open polkit-gnome-example
2. click on the _buttons_, not the menubar
  
Actual results:

<nothing happens>

Expected results:

Prompted with PolicyKit GUI helper

Additional info:

I think this is because new versions of GTK in rawhide expect widgets to implement GtkActivatable and because PolKitGnomeToggleAction doesn't, it fails to work.

This also affects other PolicyKit-gnome using applications, such as PackageKit and gnome-power-manager.
Comment 1 Richard Hughes 2009-02-06 10:40:53 EST
Output from polkit-gnome-example:

(lt-polkit-gnome-example:1771): GLib-GObject-WARNING **: invalid cast from `PolKitGnomeToggleAction' to `GtkToggleAction'
(lt-polkit-gnome-example:1771): Gtk-CRITICAL **: gtk_toggle_action_get_active: assertion `GTK_IS_TOGGLE_ACTION (action)' failed
(lt-polkit-gnome-example:1771): GLib-GObject-WARNING **: invalid cast from `PolKitGnomeToggleAction' to `GtkToggleAction'
(lt-polkit-gnome-example:1771): Gtk-CRITICAL **: gtk_toggle_action_get_active: assertion `GTK_IS_TOGGLE_ACTION (action)' failed
(lt-polkit-gnome-example:1771): GLib-GObject-WARNING **: invalid cast from `PolKitGnomeToggleAction' to `GtkToggleAction'
(lt-polkit-gnome-example:1771): Gtk-CRITICAL **: gtk_toggle_action_get_draw_as_radio: assertion `GTK_IS_TOGGLE_ACTION (action)' failed
(lt-polkit-gnome-example:1771): GLib-GObject-WARNING **: invalid cast from `PolKitGnomeToggleAction' to `GtkToggleAction'
(lt-polkit-gnome-example:1771): Gtk-CRITICAL **: gtk_toggle_action_get_active: assertion `GTK_IS_TOGGLE_ACTION (action)' failed
(lt-polkit-gnome-example:1771): GLib-GObject-WARNING **: invalid cast from `PolKitGnomeToggleAction' to `GtkToggleAction'
(lt-polkit-gnome-example:1771): Gtk-CRITICAL **: gtk_toggle_action_get_active: assertion `GTK_IS_TOGGLE_ACTION (action)' failed
(lt-polkit-gnome-example:1771): GLib-GObject-WARNING **: invalid cast from `PolKitGnomeToggleAction' to `GtkToggleAction'
(lt-polkit-gnome-example:1771): Gtk-CRITICAL **: gtk_toggle_action_get_draw_as_radio: assertion `GTK_IS_TOGGLE_ACTION (action)' failed
Comment 2 Richard Hughes 2009-02-06 13:09:38 EST
I've built http://koji.fedoraproject.org/koji/taskinfo?taskID=1109791 for rawhide that at least allows gnome-power-manager and PackageKit to work -- but I've still got to chase down a few more bugs.
Comment 3 Matthias Clasen 2009-02-13 01:56:31 EST
Should be fixed in current gtk2 packages

Note You need to log in before you can comment on or make changes to this bug.