This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 484406 - Intel 3945ABG Wireless cannot be activated
Intel 3945ABG Wireless cannot be activated
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: John W. Linville
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-06 11:35 EST by George Reeke
Modified: 2010-07-16 20:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-04 15:54:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Reeke 2009-02-06 11:35:52 EST
Description of problem:
In system-config-network the Intel 3945ABG Wireless
in my Lenovo T61 laptop is recognized as device wlan0, but any
attempt to activate it produces the error message shown below.

Version-Release number of selected component (if applicable):
1.3.99.12

How reproducible:
Every time

Steps to Reproduce:
1. Generate and select a network profile "Wireless"
2. Configure the wlan0 device for dhcp -- obtain DNS from provider
3. Click activate, answer Yes to save changes prompt
  
Actual results:
The following message appears in a popup window:
Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Invalid argument.

Determining IP information for wlan0...SIOCSIFFLAGS: No such file or directory
SIOCSIFFLAGS: No such file or directory
failed.

Expected results:
Establish wireless network connection.


Additional info:
It is known that a wireless network is active in my office
and the laptop switch to activate the wireless is on at bootup.
Prior to RHEL 5.3, the Intel wireless device was not even
recognized by the system (did not appear in hardware browser
or network configuration applet.  With 5.3, it is detected
with correct Intel name, a driver appears to be installed
(lsmod shows "iwl3945  129985 0" and "mac80211  182857 1 iwl3945"),
but any attempt to activate it produces the above SIOCS error.
Comment 1 Michael Solberg 2009-02-17 17:26:36 EST
Hello.

I have an iwl3945 and it works fine for me in RHEL 5.3.  Do you have the "iwl3945-firmware" package installed?

Michael.
Comment 2 George Reeke 2009-02-19 14:50:52 EST
Dear Michael,
   I did NOT have iwl3945-firmware installed when I posted this bug (where were the instructions to tell me I should do that??).
   Anyway, I found the package on RHN (it seems to be a noarch source rpm) and installed it and rebooted.  Now the wireless still refuses to run, but the error message has changed--the reference to SIOCSIFFLAGS is now gone.  The exact message that now pops up is this:

Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Invalid argument.

Determining IP information for wlan0...

The applet then hangs in this state until CANCEL is clicked.
This suggests that some configuration is missing.
The device was configured in the applet as follows:
Under the "General" tab:
   Allow all users to enable and disable the device
   Enable IPv6 configuration for this interface
      (same result with this IPv6 option checked or not checked)
Automatically obtain IP address settings with dhcp
Automatically obtain DNS information from provider
Under the "Route" tab:  Nothing entered
Under the "Hardware device" tab:  Bind to MAC address --
   accepted the default as given
Under the "Wireless Settings" tab:  "Auto" checked.
Comment 3 Warat C 2009-03-20 15:46:53 EDT
Ran into the same problem. After wasting a day I found this page. The iwl3945-firmware does the trick. Thanks Michael.

Reeke, I got that problem too. Try getting rid of every wireless drivers installed and start over again. I believe it's because you got 2 wireless drivers conflict with each other.

Remove all 3945 drivers that I know.
#rpm -e ipw3945-ucode ipw3945d kmod-ipw3945 iwl3945-firmware

Restart the box, then notice at the NetworkManager (top right icon on the desktop), click on it you should see Wireless Networks but there will be nothing listed on it.

Then follow Michael comment:
#yum install iwl3945-firmware

Reboot again. Now the NetworkManager should be seeing wireless network. At least this work for me on Thinkpad T60 3945abg.
Comment 4 George Reeke 2009-03-20 17:33:38 EDT
Warat C, thanks for the suggestion, this is not my problem.
Only package found with 'rpm -qa | grep 3945' is iwl3945-firmware.
I uninstalled it, re-downloaded from RHN, reinstalled, same problem.
('yum install iwl3945-firmware' does not find this package for me).
Added note:  Must be something else missing, how can a 'noarch'
package install a driver specific to an x86_64 kernel?  If I delete
file /lib/modules/2.6.18-128.el5/kernel/drivers/net/wireless/iwlwifi/
iwl3945.ko per suggestion of Warat C to delete all drivers, the
RHN package does not reinstall this file.  I also downloaded the
source tarball from the Intel site, but 'make' fails with errors,
so I gave up this idea before I could break things even worse.
G.Reeke
Comment 5 Warat C 2009-03-23 17:13:42 EDT
Try lsmod | grep 3945 and see if you got any ipw3945 module installed.

As for the yum could not find the iwl3945-firmware I believe you don't have subscription to the right software channel. Login to RHN network, click at system, select yours, then click at "Alter channel subscriptions". Check the "RHEL Desktop Supplementary (v. 5 for 64-bit x86_64)" and save.

the noarch maybe because it is actually a firmware for NIC card so it has nothing to do with OS architecture.
Comment 6 George Reeke 2009-03-24 13:00:43 EDT
Thanks for your tip regarding yum channel subscriptions.  I added the Supplementary channel as suggested.  Now "yum install iwl3945-firmware" gives this message:
"Package iwl3945-firmware-2.14.1.5-2.noarch already installed and latest version
Nothing to do"
So the subscription works.  The result is expected, given that I downloaded
and installed the package by hand earlier, as reported above.

"lsmod | grep 3945" gives no output.  Apparently something more is needed
besides this firmware package--or there is a bug relating to this machine.
Note that a driver did show up here as reported in my initial submission--
that is no longer the case for reasons unknown.  The driver iwl3945.ko is
present in /lib/modules/2.6.18-128.el5/kernel/drivers/net/wireless/iwlwifi
but not in /lib/modules/2.6.18-128.1.1.el5/kernel...etc. but the 1.1 kernel
is running.  Could this be part of the problem?

In the current configuration, attempts to start up the wireless device from the
network configuration tool now give this message:
"iwl3945 device wlan0 does not seem to be present, delaying initialization."
But note that the device does show up on the list of devices, which was not
the case before the RedHat 5.3 update.
G.Reeke
Comment 7 satheessh.c@gmail.com 2009-07-19 22:17:12 EDT
I followed below steps:

1.   Uninstalled ipw3945-ucode.noarch   1.14.2-1.el5                           
2.   Installed iwl3945-firmware.noarch       2.14.1.5-2

issue is resolved. Thanks everyone
Comment 8 George Reeke 2009-07-20 11:41:44 EDT
I attempted to perform steps given by satheessh.c.  There is no
ipw3945-ucode installed on my machine, so I cannot uninstall it.
I uninstalled and reinstalled iwl3945-firmware.noarch, using yum,
which finds and installs same version number given by satheessh,
Result is same error as given above:
Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Invalid argument.

rpm -qa | grep 3945 shows no packages installed except the one
iwl3945-firmware listed above.  I have the latest kernel downloaded
last week.  Is there some suggestion how to track down this error?
G. Reeke
Comment 9 George Reeke 2009-08-03 14:07:27 EDT
Workaround found -- Wireless works -- System hangs during shutdown

Entering the above "Set Mode (8B06)" error message into a search service,
a Ubuntu forum is found which presents the following workaround:  Create
a file /etc/modprobe.d/iwl3945 with the following contents and reboot:
alias wlan0 iwl3945
options iwl3945 disable_hw_scan=1

When this is done, the iwl3945 wireless device works.  However, a new
problem arises--when performing a system shutdown, the OS hangs
forever while attempting to shut down the wireless ethernet service.
It can only be stopped by using the power switch.

Because this workaround indeed allows the wireless to function, I will
use it for the nonce.  However, a true fix that would allow the system
to shut down normally would be much better.  I am hoping my experience
will help RedHat diagnose the problem.
G. Reeke
Comment 10 Harald Hoyer 2009-08-04 06:07:06 EDT
so this is more a kernel problem
Comment 11 John W. Linville 2009-08-04 09:26:27 EDT
George, please try the latest kernel available under here:

   http://people.redhat.com/dzickus/el5/

Does that address the shutdown problem?
Comment 12 George Reeke 2009-08-04 11:40:12 EDT
With kernel 2.6.18-160.el5 installed (3 packages: kernel, kernel-devel,
and kernel-headers), and leaving the aforementioned workaround file in
place, on bootup after selecting wireless profile, networking is not working.
The command "service network start" yields this output:
Bringing up loopback interface:                            [  OK  ]
RTNETLINK answers: File exists
[last line repeated 9 times]
and networking is still not working.
However, upon running the network configuration applet and
clicking "Activate" while the wlan0 device is selected,
first the old "Set Mode (8B06)" error message reappears, but then the
device starts and networking is OK.
Shutdown is clean, no hang as with the current distributed kernel.
Upon reboot, same thing--networking does not come automatically,
but can be started manually.
Upon removal of the workaround /etc/modprobe.d/iwl3945 file
and reboot, same thing.
Please let me know whether it is safe to continue to use this
development kernel for normal operations, or should I go back
to the current distributed version?
Thanks,
G.Reeke
Comment 13 John W. Linville 2009-08-04 15:54:24 EDT
I don't see any reason why it should be unsafe.  Whether or not it is worth putting-up with the network service not starting is up to you!  But FWIW, I can't see any reason why installing a new kernel should cause the network service to not start automatically.  You might want to open a separate bug for that.

The Set Mode error message probably results from the old RHEL5 scripts doing things in the wrong order.  I recall that we had to get that fixed in Fedora, so at least it shouldn't happen in RHEL6 when it gets here.  Anyway, this also sounds like a different issue that could merit it's own bug.

Since you got iwl3945-firmware installed and the driver can now load and work, and since the later kernels correct the shutdown problem you observed, I'm going to consider this issue closed.
Comment 14 Paulo Henrrique 2010-07-07 17:46:21 EDT
I had the same problem but i solved just deleting the files "ifup-wlan0" of my system and after my network card has worked.

The files i found at directories:

/etc/sysconfig/network-scripts/ifup-wlan0

/etc/sysconfig/networking/devices/ifup-wlan0

/etc/sysconfig/networking/profiles/default/ifup-wlan0.


I think the same should solve problem with other cards..
Comment 15 George Reeke 2010-07-08 11:13:36 EDT
That sounds like an interesting idea.  But my system doesn't have
any of those files, so I can't delete them.  I suspect Paulo had
a different problem related to an error in one of those files.
G. Reeke
Comment 16 Paulo Henrrique 2010-07-16 20:12:14 EDT
Excuse me now I find the way to enable the card but i don't know how to correct.

Its simple first i boot an livecd.

So without remove battery or power line i restart my computer removing the livecd.

And then my card its working. 

Please if you know how to correct the problem post here.

Note You need to log in before you can comment on or make changes to this bug.