Bug 484416 - R depends on R-devel ???
R depends on R-devel ???
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: R (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-06 12:38 EST by Stephen
Modified: 2009-02-07 00:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-07 00:52:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen 2009-02-06 12:38:28 EST
Description of problem:

'yum install R' wants to pull in a whole load of *-devel packages. Is this right? In this case it seems to be because R depends on R-devel. But the purpose of splitting off -devel packages is so that you can install the basic program without all the other crud.  I wonder if there's a mistake here?



Version-Release number of selected component (if applicable):

R-2.8.1-2.fc10



Steps to Reproduce:
1.  sudo yum install R


  
Actual results:


Installing:
 R                                      i386               2.8.1-2.fc10                       updates              15 k
Updating:
 libpng                                 i386               2:1.2.34-1.fc10                    updates             251 k
Installing for dependencies:
 R-core                                 i386               2.8.1-2.fc10                       updates              26 M
 R-devel                                i386               2.8.1-2.fc10                       updates              87 k
 bzip2-devel                            i386               1.0.5-3.fc10                       fedora              284 k
 cairo-devel                            i386               1.8.0-1.fc10                       fedora              177 k
 fontconfig-devel                       i386               2.6.0-3.fc10                       fedora              216 k
 freetype-devel                         i386               2.3.7-2.fc10                       updates             157 k
 kpathsea                               i386               2007-35.fc10                       fedora              115 k
 libICE-devel                           i386               1.0.4-4.fc10                       fedora               13 k
 libRmath                               i386               2.8.1-2.fc10                       updates              95 k
 libRmath-devel                         i386               2.8.1-2.fc10                       updates             123 k
 libSM-devel                            i386               1.1.0-2.fc10                       fedora               10 k
 libX11-devel                           i386               1.1.4-6.fc10                       updates             1.1 M
 libXau-devel                           i386               1.0.4-1.fc10                       fedora               11 k
 libXdmcp-devel                         i386               1.0.2-6.fc10                       fedora              8.0 k
 libXext-devel                          i386               1.0.4-1.fc9                        fedora               60 k
 libXmu-devel                           i386               1.0.4-1.fc9                        fedora               21 k
 libXrender-devel                       i386               0.9.4-3.fc9                        fedora              9.2 k
 libXt-devel                            i386               1.0.5-1.fc10                       fedora              328 k
 libjpeg-devel                          i386               6b-43.fc10                         fedora              104 k
 libpng-devel                           i386               2:1.2.34-1.fc10                    updates             107 k
 libtiff-devel                          i386               3.8.2-11.fc10                      fedora              465 k
 libxcb-devel                           i386               1.1.91-5.fc10                      fedora              144 k
 mesa-libGL-devel                       i386               7.2-0.15.fc10                      updates             460 k
 ncurses-devel                          i386               5.6-20.20080927.fc10               fedora              676 k
 netpbm                                 i386               10.35.58-1.fc10                    updates             837 k
 netpbm-progs                           i386               10.35.58-1.fc10                    updates             1.8 M
 perl-File-Copy-Recursive               noarch             0.38-1.fc10                        updates              21 k
 pixman-devel                           i386               0.12.0-2.fc10                      fedora               11 k
 psutils                                i386               1.17-29.fc10                       fedora               91 k
 readline-devel                         i386               5.2-13.fc9                         fedora              133 k
 tcl-devel                              i386               1:8.5.3-1.fc10                     fedora              171 k
 tex-preview                            noarch             11.85-7.fc9                        fedora               52 k
 texlive                                i386               2007-35.fc10                       fedora              1.9 M
 texlive-dvips                          i386               2007-35.fc10                       fedora              188 k
 texlive-latex                          i386               2007-35.fc10                       fedora               78 k
 texlive-texmf                          noarch             2007-26.fc10                       fedora              3.5 M
 texlive-texmf-dvips                    noarch             2007-26.fc10                       fedora              378 k
 texlive-texmf-errata                   noarch             2007-4.fc9                         fedora              3.7 k
 texlive-texmf-errata-dvips             noarch             2007-4.fc9                         fedora              3.6 k
 texlive-texmf-errata-fonts             noarch             2007-4.fc9                         fedora              3.7 k
 texlive-texmf-errata-latex             noarch             2007-4.fc9                         fedora              3.6 k
 texlive-texmf-fonts                    noarch             2007-26.fc10                       fedora               56 M
 texlive-texmf-latex                    noarch             2007-26.fc10                       fedora              6.0 M
 texlive-utils                          i386               2007-35.fc10                       fedora              214 k
 tk-devel                               i386               1:8.5.3-4.fc10                     fedora              520 k
 xorg-x11-proto-devel                   noarch             7.4-5.fc10                         updates             278 k
 xorg-x11-util-macros                   i386               1.1.6-2.fc10                       fedora               14 k

Transaction Summary
========================================================================================================================
Install     48 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 103 M
Is this ok [y/N]: n



Expected results:

No *-devel packages ?
Comment 1 Tom "spot" Callaway 2009-02-07 00:52:20 EST
This is not a mistake.

Before, there was R and R-devel (and libRmath and libRmath-devel). I got a lot of complaints and confused users who only installed R and tried to build their own modules from CRAN. These attempts failed, because... R-devel (and in some cases libRmath-devel) were not installed. After talking with the R upstream, who recommended strongly that functional CRAN out of the box was accepted behavior for the majority of users, I changed the R package structure slightly:

It is now composed of:

R-core (what used to be called R, doesn't have -devel deps)
R-devel (same)
libRmath (same)
libRmath-devel (same)
R (metapackage that requires R-core, R-devel, libRmath-devel)

So, if you really just want functional R and you're not concerned about being sure CRAN works out of the box, just yum install R-core.

Note You need to log in before you can comment on or make changes to this bug.