Bug 484428 - MS-SQL backend driver broken
MS-SQL backend driver broken
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: mantis (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Gianluca Sforna
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-06 13:29 EST by W. Michael Petullo
Modified: 2009-02-14 16:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-14 16:27:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2009-02-06 13:29:17 EST
Description of problem:
We have a mantis installation that uses MS-SQL as its backend database. We have found that this component has an error that keeps it from working.

Version-Release number of selected component (if applicable):
mantis-1.1.4-1.fc10.noarch

How reproducible:
Every time

Steps to Reproduce:
Install mantis and configure to use the MS-SQL backend.
  
Actual results:
Configuring the MS-SQL backend will fail when executed from the web-based admin tool. The following error is logged to Apache's log:

...call to undefined function mssql_get_last_message () in /usr/share/mantis/core/adodb/drivers/adodb-mssql.inc.php...

Expected results:


Additional info:
As a temporary work around, I modified /usr/share/mantis/core/adodb/drivers/adodb-mssql.inc.php to use the static string "unknown" instead of calling undefined function mssql_get_last_message (). This was done in two places within the source file. Once this was done, the MS-SQL backend operated as expected.
Comment 1 Gianluca Sforna 2009-02-07 04:34:26 EST
Hi, 
this is tricky for a number of reasons. For a start, I am not even sure upstream supports MSSQL officially. If they do, you will probably have more luck trying to open this bug on http://bugs.mantist.org because I have no way to test this kind of config.

On the other hand, I notice mssql_get_last_message() is really a php function so you should really have it available. Beforse going further I suggest you double check you installed the php-mssql package with:

# yum install php-mssql

and don't forget to restart apache with:
# service httpd restart

to double check if the function really exists, please install also the php-cli package and issue the command:

$ php --rf mssql_get_last_message
Function [ <internal:mssql> function mssql_get_last_message ] {
}

the output should look like mine.
Comment 2 W. Michael Petullo 2009-02-13 22:34:12 EST
Yes, php-mssql is installed.

I added a report to Mantis' tracker:

http://www.mantisbt.org/bugs/view.php?id=10131
Comment 3 Gianluca Sforna 2009-02-14 16:27:22 EST
Ok thank you very much.

I'm closing this now.

Note You need to log in before you can comment on or make changes to this bug.