Bug 484468 - NetworkManager's position in the boot order should be after nfs in order to be able to mount nfs shares
NetworkManager's position in the boot order should be after nfs in order to b...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
medium Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-06 18:35 EST by Joonas Sarajärvi
Modified: 2009-02-13 09:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 09:58:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joonas Sarajärvi 2009-02-06 18:35:18 EST
Description of problem:
I have an nfs share from a machine in the local network added to /etc/fstab. The setup works fine, but booting is greatly slowed due to a long wait while the system tries to mount the NFS share automatically. 

The relevant line from fstab:
10.10.0.200:/data /remote/tikkulehema-data nfs ro 0 0

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-1.git20090102.fc10.x86_64

How reproducible:
Happens on every boot

Steps to Reproduce:
1. Install a default Fedora installation.
2. Have an nfs share available and try to add it to /etc/fstab
3. Boot the computer
  
Actual results:
1) The system tries to mount the share while booting, but fails after trying for a while.
2) The share is mounted and available after boot, though, when NetworkManager is brought up later in the boot process.

Expected results:
The long wait and fail does not happen.

Additional info:
Comment 1 Dan Williams 2009-02-06 23:55:41 EST
Bill: whee! boot order again...  thoughts?
Comment 2 Joonas Sarajärvi 2009-02-07 00:42:10 EST
Eh... for some reason, I wrote the title totally wrong. Of course NM should be running _before_ the shares are mounted, not after. Currently it seems that NM is started only after mounting nfs shares.
Comment 3 Bill Nottingham 2009-02-10 10:32:08 EST
This is what the netfs NM dispatcher script is for.

Do you have both the network and NetworkManager service enabled?
Comment 4 Joonas Sarajärvi 2009-02-13 01:49:12 EST
Yes, I do have them both running. The secondary network card is under the traditional network service, because I need to associate the interface with a bridge.
Comment 5 Bill Nottingham 2009-02-13 09:58:54 EST
OK, this isn't fixable for that case. The netfs script is coded to only start on boot if one of network or NM is already running - since one of them is, it's going to try to mount.

If you were only running NM for all your interfaces, or only running network for all your interfaces, it should work OK as-is.

Note You need to log in before you can comment on or make changes to this bug.