Bug 484474 - F11 rawhide x86_64 won't boot after first part of install
F11 rawhide x86_64 won't boot after first part of install
Status: CLOSED DUPLICATE of bug 480667
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-06 19:05 EST by Christian Wilken
Modified: 2009-02-08 21:58 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-08 21:58:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Wilken 2009-02-06 19:05:37 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install F11 (rawhide) x86_64

  
Actual results:
After first reboot hangs with "can't mount /dev/root" (not on the actual system now)


Expected results:
Boot to finalize(/customize) installation....

Additional info:
Quick resolution:
1. Select Fedora boot option in Grub
2. Press "e" (edit)
3. Select kernel line (line no 2) and press "e" (edit)
4. Replace "root=UUID=Xxxxxxxxxxxxxxxxxxxx" with "root=/dev/vg_<hostname_as_set_earlier_in_install>/lv_root" (i.e. root=/dev/vg_localhost/lv_root)
5. Press "b" for boot... ;)
6. After installation has finished edit /boot/grub/grub.conf replacing the same line as above...
Comment 1 Andrew Hecox 2009-02-08 21:33:32 EST
I'm seeing this as well, with some differences: 

 - no LVM
 - arch == i586

The same solution works. Changing component to e2fsprogs, although I'm not sure if that's really at fault. I can re-append the UUID line and retry booting if it helps. I did *not*, unfortunately, confirm the original UUID line was correct before cutting it.
Comment 2 Andrew Hecox 2009-02-08 21:34:54 EST
also, as a quick note: the root file system is ext4, and dumpe2fs <dev> | grep UUID returns a seemingly valid result.
Comment 3 Eric Sandeen 2009-02-08 21:58:59 EST
Quoting bug 484508 comment #2 :

> mount by UUID not working in the alpha is a known problem in nash in the alpha.
> Please update to mkinitrd-6.0.76, and regenerate your initrd:
> mkinitrd -f /boot/initrd-$(uname -r).img $(uname -r)
> Then this problem should go away.

Please reopen if this is not so.

Thanks,
-Eric

*** This bug has been marked as a duplicate of bug 480667 ***

Note You need to log in before you can comment on or make changes to this bug.