Bug 484489 - messagebus fails to start if the system is configured with ldap authentication
messagebus fails to start if the system is configured with ldap authentication
Status: CLOSED DUPLICATE of bug 243753
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nss_ldap (Show other bugs)
5.3
All Linux
medium Severity high
: rc
: ---
Assigned To: Nalin Dahyabhai
BaseOS QE
bzcl34nup
:
Depends On: 206399
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-07 04:42 EST by Axel Thimm
Modified: 2009-02-07 08:39 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 206399
Environment:
Last Closed: 2009-02-07 08:39:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Axel Thimm 2009-02-07 04:42:28 EST
+++ This bug was initially created as a clone of Bug #206399 +++

Description of problem:
The script /etc/init.d/messagebus hangs during bootup if the system is
configured for LDAP authentication. Disabling LDAP authentication solves the
problem.

_____________________________________________________________________

The problems described in the bug above exist in RHEL5 since 5.0.

If the server rebooting is ldap-serving itself, dbus hangs during reboots. In a debugging session, ensuring that ldap starts before messagebus solved the issue.

So it either needs a reordering of the boot sequence of the services (e.g. move ldap to the front of any consuming service), or some nss_ldap magic.
Comment 1 Axel Thimm 2009-02-07 06:47:34 EST
The fix was in the /etc/ldap.conf.rpmnew file. Sorry for the noise.

--------------------------

I can't close this as a duplicate of bug #243753, as bugzilla says:

 You tried to change the Status field from NEW  to CLOSED,
 but only a user with the required permissions may change that field.

 Please press Back and try again.

Can someone with sufficient permissions close this as a duplicate of bug #243753? Thanks!
Comment 2 Jose Plans 2009-02-07 08:39:11 EST
Sure, thanks!

*** This bug has been marked as a duplicate of bug 243753 ***
Comment 3 Jose Plans 2009-02-07 08:39:31 EST
Sure, thanks!

Note You need to log in before you can comment on or make changes to this bug.