Bug 484496 - Boot failure on mtd0 (using mkliveinitrd)
Boot failure on mtd0 (using mkliveinitrd)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-07 08:29 EST by Marco Pesenti Gritti
Modified: 2009-07-21 14:31 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-21 14:31:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marco Pesenti Gritti 2009-02-07 08:29:57 EST
On Fedora 10, provided that cafe_nand and jffs2 modules are included, we can build a functional initrd to boot from the OLPC nand. This was regressed in rawhide by this commit:

http://git.fedorahosted.org/git/?p=mkinitrd;a=commit;h=24d6d9779ca5bacc0c649e9d783263661ceb81f0

We run vol_id on /dev/root, which in the mtd0 case does not exist, and we die.
Comment 1 Jeremy Katz 2009-02-10 14:13:03 EST
Fixed in git, will build a new mkinitrd shortly

Thanks for tracking this down!
Comment 3 Scott Douglass 2009-03-16 22:36:01 EDT
This issue is not fixed in rawhide on XO.

Installing any kernel RPM yields an initrd that can't boot because "mtd0 is not a block device, skipping".

mkinitrd-6.0.80-1.fc11.i586
Comment 4 Bug Zapper 2009-06-09 07:07:07 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Jeremy Katz 2009-07-21 14:31:21 EDT
Closing out bug that's been in MODIFIED for a while.

Note You need to log in before you can comment on or make changes to this bug.