Bug 484514 - fonts in gs
fonts in gs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-02-07 12:36 EST by acount closed by user
Modified: 2009-02-24 07:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 07:14:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description acount closed by user 2009-02-07 12:36:57 EST
don't delete Font dir on the spec file:

# Don't ship URW fonts; we already have them.
rm -rf $RPM_BUILD_ROOT%{_datadir}/ghostscript/%{gs_dot_ver}/Resource/Font

because urw-fonts-2.4-6 are older(and with bugs) than the fonts included in gs.

or get it a new urw-fonts code from http://svn.ghostscript.com/ghostscript/trunk/urw-fonts/ . There is no more ftp://ftp.gnome.ru/fonts/sources

-thanks-
Comment 1 acount closed by user 2009-02-07 12:54:45 EST
also the ghostscript-fonts package must be deleted, because they are the _same_ fonts than urw-fonts. It's a pure "GNU" package when gs was not free!
Comment 2 Nicolas Mailhot 2009-02-17 13:12:13 EST
And anyway they both need to get fixed for F11 font infra changes or they won't be functional for F11 users

bug #477389
bug #477477

Behdad's and Hughsie's stuff assumes sane packages have been converted by release tiume by their maintainers.
Comment 3 Tim Waugh 2009-02-23 12:57:24 EST
(In reply to comment #1)
> also the ghostscript-fonts package must be deleted, because they are the _same_
> fonts than urw-fonts. It's a pure "GNU" package when gs was not free!

I don't think this is true actually.  There are fonts shipped in ghostscript-fonts that are not shipped in urw-fonts or ghostscript, such as Hershey and Calligraphic-Katakana/Hiragana.
Comment 4 Ngo Than 2009-02-24 07:00:05 EST
># Don't ship URW fonts; we already have them.
>rm -rf $RPM_BUILD_ROOT%{_datadir}/ghostscript/%{gs_dot_ver}/Resource/Font
>
>because urw-fonts-2.4-6 are older(and with bugs) than the fonts included in >gs.
>

i don't think the urw-fonts-2.4-6 are older. The gs fonts in trunk are still based on 1.0.7pre43. The urw-fonts-2.4-6 are based on 1.0.7pre44 and it includes several fixes.

It's correct that ghostscript removes the fonts included in gs

>or get it a new urw-fonts code from
>http://svn.ghostscript.com/ghostscript/trunk/urw-fonts/ . There is no more
>ftp://ftp.gnome.ru/fonts/sources

it's correct that the url ftp://ftp.gnome.ru/fonts/sources is not reachable, i tried to contact Valek but still didn't get any respone yet.


> also the ghostscript-fonts package must be deleted, because they are the >_same_fonts than urw-fonts. It's a pure "GNU" package when gs was not free!

no, it's not the same fonts what are in urw-fonts shipped.

Note You need to log in before you can comment on or make changes to this bug.