Bug 484526 - epiphany process stays around even when quitted
epiphany process stays around even when quitted
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-07 16:47 EST by Jon Dufresne
Modified: 2010-06-28 07:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 07:12:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full backtrace when bug occurs (10.58 KB, text/plain)
2009-02-08 22:54 EST, Jon Dufresne
no flags Details
PA error message from /var/log/messages (4.43 KB, text/plain)
2009-04-12 15:04 EDT, Joachim Frieben
no flags Details
PA error message from /var/log/messages on some x86_64 system (1.98 KB, text/plain)
2009-04-13 06:39 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Jon Dufresne 2009-02-07 16:47:03 EST
I don't know if this bug is a result of epiphany failing to start properly, or failing to close properly from the previous session. I open epiphany from the applications menu. I see the "starting epiphany" in the taskbar for a short while. Then it goes away and I see nothing. If I run "ps -ef" I see an epiphany process running, but no epiphany window on any of the desktops. The only way to work around this is to kill the running epiphany process on the command line and then on the next time epiphany starts it opens normally. I attached to the process when this occured and grabbed a backtrace.

I have the following in the plugin directory:
ls -l /usr/lib/mozilla/plugins/
total 500
lrwxrwxrwx 1 root root     34 2009-01-09 13:34 libjavaplugin.so -> /etc/alternatives/libjavaplugin.so
-rwxr-xr-x 1 root root   4076 2009-01-19 08:46 librhythmbox-itms-detection-plugin.so
-rwxr-xr-x 1 root root  60424 2008-10-24 07:19 libswfdecmozilla.so
-rwxr-xr-x 1 root root  68512 2008-10-26 09:47 libtotem-basic-plugin.so
-rwxr-xr-x 1 root root  94568 2008-10-26 09:47 libtotem-cone-plugin.so
-rwxr-xr-x 1 root root 102688 2008-10-26 09:47 libtotem-gmp-plugin.so
-rwxr-xr-x 1 root root  68568 2008-10-26 09:47 libtotem-mully-plugin.so
-rwxr-xr-x 1 root root  77088 2008-10-26 09:47 libtotem-narrowspace-plugin.so

----
(gdb) bt
#0  0x00d9c416 in __kernel_vsyscall ()
#1  0x00ca3c07 in pthread_join (threadid=3029375888, thread_return=0xbfedb41c) at pthread_join.c:89
#2  0x051d3fda in PR_JoinThread (thred=0x90cf300) at ../../../mozilla/nsprpub/pr/src/pthreads/ptthread.c:594
#3  0x019caa49 in nsPSMBackgroundThread::requestExit (this=0x904aa08) at nsPSMBackgroundThread.cpp:97
#4  0x019d21d7 in nsNSSComponent::DoProfileChangeNetTeardown (this=0x904a858) at nsNSSComponent.cpp:2339
#5  0x019d57f3 in nsNSSComponent::Observe (this=0x904a858, aSubject=0x0, aTopic=0x813f0bb "profile-change-net-teardown", someData=0x0) at nsNSSComponent.cpp:2088
#6  0x01b9d18a in nsObserverList::NotifyObservers (this=0x8f2c284, aSubject=0x0, aTopic=0x813f0bb "profile-change-net-teardown", someData=0x0) at nsObserverList.cpp:128
#7  0x01b9d4ee in nsObserverService::NotifyObservers (this=0x89004d8, aSubject=0x0, aTopic=0x813f0bb "profile-change-net-teardown", someData=0x0) at nsObserverService.cpp:181
#8  0x080ce942 in EphySingle::Detach (this=0x8a9d3a0) at EphySingle.cpp:97
#9  0x080bf403 in mozilla_embed_single_dispose (object=0x8601228) at mozilla-embed-single.cpp:742
#10 0x009e82c8 in IA__g_object_unref (_object=0x8601228) at gobject.c:2389
#11 0x080f78f3 in ephy_embed_shell_finalize (object=0x85ef408) at ephy-embed-shell.c:139
#12 0x080777c1 in ephy_shell_finalize (object=0x85ef408) at ephy-shell.c:349
#13 0x009e8363 in IA__g_object_unref (_object=0x85ef408) at gobject.c:2417
#14 0x0807cb39 in ephy_window_finalize (object=0x8ab6020) at ephy-window.c:3468
#15 0x009e8363 in IA__g_object_unref (_object=0x8ab6020) at gobject.c:2417
#16 0x02c5b333 in IA__gtk_main_do_event (event=0x8eea640) at gtkmain.c:1545
#17 0x0065f2fa in gdk_event_dispatch (source=0x85b9af8, callback=0, user_data=0x0) at gdkevents-x11.c:2365
#18 0x04c07238 in g_main_dispatch () at gmain.c:2144
#19 IA__g_main_context_dispatch (context=0x85b9b40) at gmain.c:2697
#20 0x04c0a8e3 in g_main_context_iterate (context=0x85b9b40, block=1, dispatch=1, self=0x8595458) at gmain.c:2778
#21 0x04c0ae02 in IA__g_main_loop_run (loop=0x8aa9110) at gmain.c:2986
#22 0x02c5b959 in IA__gtk_main () at gtkmain.c:1200
#23 0x08071f80 in main (argc=1, argv=0xbfedca74) at ephy-main.c:738
----
Comment 1 Matěj Cepl 2009-02-08 11:09:47 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

First of all, could we get output of the command

	rpm -qa *xulrun* *epiphany* *mozilla* *flash* *plugin*

Please also install epiphany-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install epiphany

Then run command

gdb epiphany

That will start epiphany running inside of gdb debugger. Then use command run and do whatever you did to make epiphany crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Jon Dufresne 2009-02-08 22:50:13 EST
I can provide anything you need. Here is what you asked for.

----
$ rpm -qa *xulrun* *epiphany* *mozilla* *flash* *plugin*
gstreamer-plugins-base-0.10.21-2.fc10.i386
gstreamer-plugins-base-devel-0.10.21-2.fc10.i386
nspluginwrapper-debuginfo-1.3.0-2.fc10.i386
PackageKit-yum-plugin-0.3.13-1.fc10.i386
swfdec-mozilla-debuginfo-0.8.2-1.fc10.i386
gstreamer-plugins-good-0.10.11-4.fc10.i386
gstreamer-plugins-bad-0.10.9-1.fc10.i386
mozilla-filesystem-1.9-2.fc10.i386
gstreamer-plugins-bad-devel-0.10.9-1.fc10.i386
gstreamer-plugins-flumpegdemux-0.10.15-4.fc10.i386
epiphany-debuginfo-2.24.3-2.fc10.i386
xulrunner-1.9.0.6-1.fc10.i386
plymouth-plugin-label-0.6.0-0.2008.11.17.3.fc10.i386
plymouth-system-plugin-0.6.0-0.2008.11.17.3.fc10.i386
anaconda-yum-plugins-1.0-3.fc10.noarch
totem-mozplugin-2.24.3-1.fc10.i386
swfdec-mozilla-0.8.2-1.fc10.i386
java-1.6.0-openjdk-plugin-1.6.0.0-9.b14.fc10.i386
epiphany-extensions-2.24.0-4.fc10.i386
gstreamer-plugins-good-devel-0.10.11-4.fc10.i386
epiphany-extensions-debuginfo-2.24.0-4.fc10.i386
gstreamer-plugins-base-debuginfo-0.10.21-2.fc10.i386
setroubleshoot-plugins-2.0.12-1.fc10.noarch
PackageKit-gstreamer-plugin-0.3.13-1.fc10.i386
xulrunner-debuginfo-1.9.0.6-1.fc10.i386
alsa-plugins-pulseaudio-1.0.18-2.fc10.i386
gstreamer-plugins-farsight-0.12.9-3.fc10.i386
nspluginwrapper-1.3.0-2.fc10.i386
epiphany-2.24.3-2.fc10.i386
gstreamer-plugins-ugly-0.10.10-2.fc10.i386
plymouth-plugin-solar-0.6.0-0.2008.11.17.3.fc10.i386
xulrunner-devel-1.9.0.6-1.fc10.i386
----

When I run epiphany directly from the command line when this bug occurs I see the following:

----
$ epiphany

** (epiphany:3467): WARNING **: An error occurred while calling remote method: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
----

After this WARNING occurs, epiphany exits normally and I am therefore unable to get a backtrace by running "gdb epiphany". However, when this WARNING occurs there is already a running process of epiphany (the previous session likely didn't close correctly). If I attach to this process using "gdb epiphany <epiphany pid>" I can get a backtace which I will attach.
Comment 3 Jon Dufresne 2009-02-08 22:54:38 EST
Created attachment 331276 [details]
full backtrace when bug occurs
Comment 4 Joachim Frieben 2009-04-12 14:20:38 EDT
I do see the same problem on both i386 and x86_64 "rawhide" systems. It appears to be accompanied by a loss of system sound. I can trigger this quickly by playing a flash movie. After maybe 30 secs, sound gets lost. The bell sound falls back from the GNOME sound to a plain beep. When trying to log out, a message window reporting a running epiphany process is issued althoug there is no open window.
Error log .xsession-errors contains the following section:

 ** (gnome-volume-control-applet:2776): WARNING **: Connection failed

 ** (epiphany:3454): WARNING **: An error occurred while calling remote method:
 Did not receive a reply. Possible causes include: the remote application did
 not send a reply, the message bus security policy blocked the reply, the reply
 timeout expired, or the network connection was broken.

Is this an epiphany only issue?
Comment 5 Joachim Frieben 2009-04-12 15:04:29 EDT
Created attachment 339259 [details]
PA error message from /var/log/messages
Comment 6 Joachim Frieben 2009-04-13 06:39:19 EDT
Created attachment 339307 [details]
PA error message from /var/log/messages on some x86_64 system

Similar output to /var/log/messages for an x86_64 system. The PA process dies in the very same moment when this happens.
Comment 7 Joachim Frieben 2009-04-13 16:44:50 EDT
The issue [snd_pcm_avail() returned a value that is exceptionally large] appears to be solved for me by kernel-2.6.29.1-70.fc11.x86_64:
- merge alsa fixes from wwoods: ..
Comment 8 Jon Dufresne 2009-05-18 11:52:55 EDT
I upgraded to Fedora 11 with kernel 2.6.29.3-140 and this problem still exists. This bug creates a real usability problem. If the bug occurs and I attempt to quit epiphany, the only way I can start epiphany again is if kill the previous process.
Comment 9 Jon Dufresne 2009-05-18 11:56:19 EDT
Also, I do not see the alsa errors in my /var/log/messages as reported by others.
Comment 10 Bug Zapper 2009-06-09 07:07:28 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bug Zapper 2010-04-27 08:52:41 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Bug Zapper 2010-06-28 07:12:26 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.