Bug 484530 - Unplugging CDMA modem doesn't update active connections
Unplugging CDMA modem doesn't update active connections
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-07 18:57 EST by Daniel Mircea
Modified: 2009-05-12 00:07 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.7.0.99-4.git20090324.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 12:12:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update bug (81.33 KB, image/png)
2009-02-07 19:00 EST, Daniel Mircea
no flags Details
lshal --monitor (711 bytes, application/octet-stream)
2009-02-15 06:43 EST, Daniel Mircea
no flags Details
/sbin/udevadm monitor (5.98 KB, application/octet-stream)
2009-02-15 06:44 EST, Daniel Mircea
no flags Details
lshal output (19.99 KB, application/x-gzip)
2009-02-15 11:39 EST, Daniel Mircea
no flags Details

  None (edit)
Description Daniel Mircea 2009-02-07 18:57:41 EST
Description of problem:
I'm connecting to the internet by using a CDMA modem. Occasionally I have to use it on a secondary PC. It's very convenient to unplug it directly rather than disconnecting. Everything works ok, the programs enter offline mode as they should but nm-applet still displays the connection(device). Repeating this step will leave another active connection, which can look quite ugly after doing this a couple of times(see attached).

Steps to Reproduce:
1. Plug the usb CDMA modem and connect
2. Unplug the modem (without using disconnect)
3. n/a
Comment 1 Daniel Mircea 2009-02-07 19:00:47 EST
Created attachment 331219 [details]
Update bug
Comment 2 Dan Williams 2009-02-12 18:13:23 EST
Next time you want to just unplug without disconnecting, can you:

1) Open a terminal (as your user), and run the command "lshal --monitor"
2) Open another terminal, and (as root) run "/sbin/udevadm monitor"

Then, while you're connected, unplug the modem.  Attach the output from both terminals.  What we're looking for here is whether it's a kernel problem or a NetworkManager problem.  We can figure this out by looking at whether udev and hal recognize the device unplug.  Thanks!
Comment 3 Daniel Mircea 2009-02-15 06:43:27 EST
Created attachment 331960 [details]
lshal --monitor
Comment 4 Daniel Mircea 2009-02-15 06:44:37 EST
Created attachment 331961 [details]
/sbin/udevadm monitor
Comment 5 Dan Williams 2009-02-15 09:16:49 EST
Ok, same thing, but after you unplug without disconnecting and NM shows the issue, can you grab the output of just "lshal" (ie, without the --monitor)?
Comment 6 Daniel Mircea 2009-02-15 11:39:32 EST
Created attachment 331975 [details]
lshal output

The archive contains both the lshal output when the modem is connected (lshal_output_before) and after it gets disconnected(lshal_output_after). 
I figured you can use diff or something similar to find what you're looking for.
Comment 7 Dan Williams 2009-03-03 15:43:08 EST
The lshal output looks OK, moves some suspicion back to NM itself.  I guess we need to do some scrach builds with more debugging info.
Comment 8 Dan Williams 2009-03-24 07:28:40 EDT
This actually turns out to be a kernel bug with the PPP layer; worked around in NM for now.
Comment 9 Fedora Update System 2009-03-24 10:54:42 EDT
NetworkManager-0.7.0.99-4.git20090324.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0.99-4.git20090324.fc10
Comment 10 Fedora Update System 2009-03-24 10:57:53 EDT
NetworkManager-0.7.0.99-4.git20090324.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0.99-4.git20090324.fc9
Comment 11 Fedora Update System 2009-03-25 12:12:00 EDT
NetworkManager-0.7.0.99-4.git20090324.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-03-26 18:05:12 EDT
NetworkManager-0.7.0.99-5.git20090326.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0.99-5.git20090326.fc9
Comment 13 Fedora Update System 2009-04-08 23:04:25 EDT
NetworkManager-0.7.0.100-2.git20090408.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0.100-2.git20090408.fc9
Comment 14 Fedora Update System 2009-04-14 21:23:50 EDT
NetworkManager-0.7.1-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.1-1.fc9
Comment 15 Fedora Update System 2009-05-12 00:07:03 EDT
NetworkManager-0.7.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.