Bug 484533 - RS690, rotated display, black area, regression
RS690, rotated display, black area, regression
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-07 19:26 EST by Jan Martinek
Modified: 2009-09-04 09:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-04 09:22:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log for xorg-x11-drv-ati-6.9.0-62.fc10.x86_64 (96.41 KB, text/plain)
2009-02-09 02:20 EST, Jan Martinek
no flags Details
Xorg log for xorg-x11-drv-ati-6.9.0-63.fc11.x86_64.rpm (120.61 KB, text/plain)
2009-02-09 02:20 EST, Jan Martinek
no flags Details

  None (edit)
Description Jan Martinek 2009-02-07 19:26:34 EST
Description of problem:
All versions from
xorg-x11-drv-ati-6.9.0-63.fc11.x86_64
till
xorg-x11-drv-ati-6.10.0-2.fc11.x86_64.rpm

have the same issue concerning display rotation. The rotated display using
xrandr -o left
looks like this:

------------
|          |
|          |
|          |
|          |
|          |
|          |
|black area|
------------

I wanted to make a screenshot, but everything looks fine on it and the black area is not there.
I did not measure it but I THINK the black area is 1280-1024=256 pixels high.

I am now using xorg-x11-drv-ati-6.9.0-62.fc10.x86_64.rpm and the rotation works perfectly. But I must not upgrade to anything newer.
Comment 1 Matěj Cepl 2009-02-08 11:10:16 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Jan Martinek 2009-02-09 02:20:00 EST
Created attachment 331287 [details]
Xorg log for xorg-x11-drv-ati-6.9.0-62.fc10.x86_64
Comment 3 Jan Martinek 2009-02-09 02:20:59 EST
Created attachment 331288 [details]
Xorg log for xorg-x11-drv-ati-6.9.0-63.fc11.x86_64.rpm
Comment 4 Jan Martinek 2009-02-09 02:22:57 EST
Sorry, I forgot the log files. There is a difference between versions *62 and *63 so I attach logs for both of them. The configuration file is not available.
Comment 5 Michal Schmidt 2009-04-24 08:43:56 EDT
Hi Jan,

I saw a similar problem but it's been fixed recently. Can you retest with the latest version?
Comment 6 Bug Zapper 2009-06-09 07:08:02 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Jan Martinek 2009-09-04 09:12:19 EDT
Hello,

I am now using
xorg-x11-drv-ati-6.12.2-14.fc11.x86_64
2.6.29.5-191.fc11.x86_64
(kernel mode setting active)
and this problem is gone. I do not know since when.

Thanks everyone.
Comment 8 Michal Schmidt 2009-09-04 09:22:43 EDT
Thanks, closing.

Note You need to log in before you can comment on or make changes to this bug.