Bug 484547 - Review Request: pyfacebook - Python wrapper for Facebook's API
Review Request: pyfacebook - Python wrapper for Facebook's API
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Conrad Meyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 484548
  Show dependency treegraph
 
Reported: 2009-02-08 03:45 EST by Ian Weller
Modified: 2009-06-26 10:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 10:47:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
konrad: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)
Review (8.31 KB, text/plain)
2009-02-12 02:58 EST, Conrad Meyer
no flags Details

  None (edit)
Description Ian Weller 2009-02-08 03:45:06 EST
Spec URL: http://ianweller.fedorapeople.org/SRPMS/pyfacebook/0.1-1.20090208svn173/pyfacebook.spec
SRPM URL: http://ianweller.fedorapeople.org/SRPMS/pyfacebook/0.1-1.20090208svn173/pyfacebook-0.1-1.20090208svn173.fc10.src.rpm

Description:
PyFacebook is a thin wrapper for accessing Facebook's RESTful API through
Python.
Comment 1 Conrad Meyer 2009-02-12 02:58:49 EST
Created attachment 331664 [details]
Review

Initial review.
Comment 2 Ian Weller 2009-02-12 11:48:28 EST
> - [ BAD ] MUST: The package must meet the Packaging Guidelines.

> http://wiki.developers.facebook.com/index.php/Python says there has not
> yet been a release. The Version should be 0 and Release should follow
> the pre-release guidelines:
> http://fedoraproject.org/wiki/Packaging/NamingGuidelines#Pre-Release_packages

However, a version is given with the package, and this version is used in the Python egg distributed with the package.

http://code.google.com/p/pyfacebook/source/browse/trunk/setup.py#6
Comment 3 Conrad Meyer 2009-02-12 20:00:45 EST
(In reply to comment #2)
> However, a version is given with the package, and this version is used in the
> Python egg distributed with the package.
> 
> http://code.google.com/p/pyfacebook/source/browse/trunk/setup.py#6

Then the version is ok. You still need to follow the pre-release guidelines and use a 0.X release tag.
Comment 4 Ian Weller 2009-03-08 18:08:41 EDT
ping?
Comment 5 Conrad Meyer 2009-03-08 18:14:31 EDT
Have you updated your spec to follow the pre-release naming guidelines (or has upstream released a stable version)? If so, please post URLs to the updated spec.
Comment 7 Conrad Meyer 2009-03-08 18:42:20 EDT
Looks good, APPROVED. Thanks for packaging this :).
Comment 8 Ian Weller 2009-03-08 19:38:03 EDT
New Package CVS Request
=======================
Package Name: pyfacebook
Short Description: Python wrapper for Facebook's API
Owners: ianweller
Branches: F-10 EL-5
Comment 9 Ian Weller 2009-03-08 19:38:36 EDT
oh and of course -- thanks, conrad :)
Comment 10 Kevin Fenzi 2009-03-09 11:52:27 EDT
cvs done.
Comment 11 Ian Weller 2009-03-09 16:08:29 EDT
thanks kevin :)
Comment 12 Conrad Meyer 2009-03-20 20:05:41 EDT
Once you've imported and built this in rawhide, feel free to close this bug as CLOSED RAWHIDE :).

Note You need to log in before you can comment on or make changes to this bug.