Bug 484549 - Example scripts do not run on x86_64
Example scripts do not run on x86_64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pigment-python (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-08 03:50 EST by Trond Danielsen
Modified: 2009-02-09 06:04 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.3.14-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-09 06:04:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trond Danielsen 2009-02-08 03:50:17 EST
Description of problem:


Version-Release number of selected component (if applicable):
pigment-0.3.14-1
pigment-python-0-3.10-1


Steps to Reproduce:
1. [trondd@niobium ~]$ python /usr/share/doc/pigment-python-0.3.10/examples/sphere.py 

Actual results:
The program 'sphere.py' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadLength (poly request too large or internal Xlib length erro'.
  (Details: serial 15 error_code 16 request_code 143 minor_code 17)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


Expected results:


Additional info:
The problem is the same as described in #479098 which was solved in 0.3.13-3.

Note: I tested this on F10, but the packages were from rawhide.
Comment 1 Matthias Saou 2009-02-09 06:04:47 EST
There is a workaround in the package to fix this, and I tried removing it again, but tested on i386 only, so I thought things were working... but no. You want to be using 0.3.14-2.

Note also that my rebuilds of pigment-python for F-10 and F-9 are failing because the pigment rebuilds aren't available to them. I really don't know why this is happening now...

Note You need to log in before you can comment on or make changes to this bug.