Bug 484588 - Boot fails attempting to run fsck on LVM volume on SCSI drive.
Boot fails attempting to run fsck on LVM volume on SCSI drive.
Status: CLOSED DUPLICATE of bug 474846
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-08 14:19 EST by Michael Eager
Modified: 2014-03-16 23:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-10 10:35:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Eager 2009-02-08 14:19:00 EST
Description of problem:
Boot fails while running fsck on LVM volume, dropping to maintenance mode.  If /etc/fstab is modified to not mount LVM volumes on SCSI drives, boot completes and it is possible to run pvscan/vgchange to recognize LVM volume and mount them.  

Version-Release number of selected component (if applicable):
Fedora 10

How reproducible:
Every time system boots, with fstab mounting LVM volume on SCSI drive.

Steps to Reproduce:
1.  Install F10 on system with ATA and SCSI drives
2.  / and /boot on ATA
3.  fstab mount LVM from SCSI drive
  
Actual results:
Fsck fails, boot drops into maintenance mode.

Expected results:
System boot completely, mounting LVM volumes.

Additional info:
When rc.sysinit runs vgchange, only LVMs on ATA drive are found.  /sbin/fdisk -l at the same time does not see SCSI drives.  

This may be similar to problems with mkinitrd, where the SCSI controller is not stabilized before attempting to mount / from LVM or SCSI drive: see 466071, 466607, 483423.  Mkinitrd fix doesn't appear to address this, since this failure is happening after initrd script reboots.  

It seems likely that this could be intermittent and/or timing related on some systems, depending on whether the SCSI drives are stabilized or not.  

A fix/workaround is to load/remove scsi_wait_scan in /etc/rc.sysinit, similar to that in mkinitrd, before starting RAID or LVM:

--- /etc/rc.sysinit-orig        2009-02-08 10:14:29.000000000 -0800
+++ /etc/rc.sysinit     2009-02-08 10:14:42.000000000 -0800
@@ -336,6 +336,9 @@
 update_boot_stage RChostname
 action $"Setting hostname ${HOSTNAME}: " hostname ${HOSTNAME}

+action $"Waiting for scsi:" modprobe scsi_wait_scan
+rmmod scsi_wait_scan
+
 # Start any MD RAID arrays that haven't been started yet
 [ -f /etc/mdadm.conf -a -x /sbin/mdadm ] && /sbin/mdadm -As --auto=yes --run

Probably this fix should test if there are SCSI drives installed.  

This may be the same problem as 448576, 451837, 474846, although there are comments about mkinitrd.
Comment 1 Bill Nottingham 2009-02-10 10:35:46 EST

*** This bug has been marked as a duplicate of bug 474846 ***

Note You need to log in before you can comment on or make changes to this bug.