Bug 484604 - OpenOffice.org 3 crashes in glyph substitution
Summary: OpenOffice.org 3 crashes in glyph substitution
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 10
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 484727 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-02-08 23:29 UTC by Trevor Spiteri
Modified: 2009-03-16 19:39 UTC (History)
4 users (show)

Fixed In Version: 3.0.1-15.3.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-16 19:39:05 UTC


Attachments (Terms of Use)
.ppt that causes crash (1.00 MB, application/vnd.ms-powerpoint)
2009-02-09 21:08 UTC, Trevor Spiteri
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 99081 None None None Never

Description Trevor Spiteri 2009-02-08 23:29:54 UTC
I was viewing a ppt file in Impress, and Impress crashed. A window with the title "OOo has crashed!: Paste this text into your bug report" popped up. My mouse was not working; in order to kill the openoffice.org process and copy the text, I had to press Ctl-Alt-F2 to log in in a virtual console outside of X. The contents of the window:

(I)    x.org loaded video driver of...
(II) Loading /usr/lib64/xorg/modules/drivers//intel_drv.so
(II) Loading /usr/lib64/xorg/modules/drivers//fbdev_drv.so
(II) Loading /usr/lib64/xorg/modules/drivers//vesa_drv.so
(II) Unloading /usr/lib64/xorg/modules/drivers//fbdev_drv.so
(II) Unloading /usr/lib64/xorg/modules/drivers//vesa_drv.so
(==) Depth 24 pixmap format is 32 bpp
(III)  Desktop is: GNOME
(IV)   openoffice.org-kde version is: package openoffice.org-kde is not installed
(V)    libgcj version is: libgcj-4.3.2-7-x86_64
(VI)   kernel is: Linux 2.6.27.12-170.2.5.fc10.x86_64 #1 SMP Wed Jan 21 01:33:24 EST 2009 x86_64 x86_64 x86_64
(VII)  OpenOffice.org core rpm version is: openoffice.org-core-3.0.1-15.2.fc10-x86_64
(VIII) accessibility is: false
(IX)   fedora release is: Fedora release 10 (Cambridge)
(X)    LANG is: en_GB.UTF-8
...start free space details ...
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                      92567560  52416828  35448524  60% /
/dev/mapper/VolGroup00-LogVol00
                      92567560  52416828  35448524  60% /
...end free space details ...
...start (default) java details ...
java version "1.6.0_0"
IcedTea6 1.4 (fedora-9.b14.fc10-x86_64) Runtime Environment (build 1.6.0_0-b14)
OpenJDK 64-Bit Server VM (build 14.0-b08, mixed mode)
...end (default) java details ...
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 23
Policy from config file:        targeted
...end sestatus details ...
...start stackreport details ...
0x3b70037c2b: 0x1eb8a8: /usr/lib64/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3 + 0x37c2b
0x3b70038843: 0x1eb8a8: /usr/lib64/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3 + 0x38843
0x31cec0f0f0: 0x16da8: /lib64/libpthread.so.0 + 0xf0f0
0x3b7258b3cb: 0x3f0dc8: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0x18b3cb (ImplDevFontList::GetGlyphFallbackFont(ImplFontSelectData&, rtl::OUString&, int) const + 0x17b)
0x3b7258fab6: 0x3f0dc8: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0x18fab6
0x3b725914f5: 0x3f0dc8: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0x1914f5
0x3b72592f4e: 0x3f0dc8: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0x192f4e
0x3b7259942d: 0x3f0dc8: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0x19942d (OutputDevice::DrawTextArray(Point const&, String const&, int const*, unsigned short, unsigned short) + 0xdd)
0x3b72532769: 0x3f0dc8: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0x132769 (GDIMetaFile::Play(OutputDevice*, unsigned long) + 0x109)
0x3b72532a07: 0x3f0dc8: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0x132a07 (GDIMetaFile::Play(OutputDevice*, Point const&, Size const&, unsigned long) + 0x247)
0x3b725462fd: 0x3f0dc8: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0x1462fd
0x3e6fe0e1bf: 0xe10f18: /usr/lib64/openoffice.org3/program/../basis-link/program/libsvxlx.so + 0x40e1bf
0x3e6fe1258e: 0xe10f18: /usr/lib64/openoffice.org3/program/../basis-link/program/libsvxlx.so + 0x41258e (SdrOle2Obj::DoPaintObject(XOutputDevice&, SdrPaintInfoRec const&) const + 0x18e)
0x3e703d9478: 0xe10f18: /usr/lib64/openoffice.org3/program/../basis-link/program/libsvxlx.so + 0x9d9478 (sdr::contact::ViewContactOfSdrObj::PaintObject(sdr::contact::DisplayInfo&, Rectangle&, sdr::contact::ViewObjectContact const&) + 0x58)
0x3e703dff6b: 0xe10f18: /usr/lib64/openoffice.org3/program/../basis-link/program/libsvxlx.so + 0x9dff6b (sdr::contact::ViewObjectContact::PaintObject(sdr::contact::DisplayInfo&) + 0xdb)
0x3e725a9a5c: 0x626ee0: /usr/lib64/openoffice.org3/program/../basis-link/program/libsdlx.so + 0x1a9a5c
0x3e703dfd72: 0xe10f18: /usr/lib64/openoffice.org3/program/../basis-link/program/libsvxlx.so + 0x9dfd72 (sdr::contact::ViewObjectContact::PaintObjectHierarchy(sdr::contact::DisplayInfo&) + 0xd2)
0x3e703dfe5b: 0xe10f18: /usr/lib64/openoffice.org3/program/../basis-link/program/libsvxlx.so + 0x9dfe5b (sdr::contact::ViewObjectContact::PaintDrawHierarchy(sdr::contact::DisplayInfo&) + 0x7b)
0x3e703dfd05: 0xe10f18: /usr/lib64/openoffice.org3/program/../basis-link/program/libsvxlx.so + 0x9dfd05 (sdr::contact::ViewObjectContact::PaintObjectHierarchy(sdr::contact::DisplayInfo&) + 0x65)
0x3e703df60a: 0xe10f18: /usr/lib64/openoffice.org3/program/../basis-link/program/libsvxlx.so + 0x9df60a
0x3e703df803: 0xe10f18: /usr/lib64/openoffice.org3/program/../basis-link/program/libsvxlx.so + 0x9df803
0x3e6fef1a62: 0xe10f18: /usr/lib64/openoffice.org3/program/../basis-link/program/libsvxlx.so + 0x4f1a62 (SdrPageWindow::RedrawAll(unsigned short, sdr::contact::ViewObjectContactRedirector*) const + 0x242)
0x3e6fe5de83: 0xe10f18: /usr/lib64/openoffice.org3/program/../basis-link/program/libsvxlx.so + 0x45de83 (SdrPaintView::CompleteRedraw(OutputDevice*, Region const&, unsigned short, sdr::contact::ViewObjectContactRedirector*) + 0x73)
0x3e725a91f4: 0x626ee0: /usr/lib64/openoffice.org3/program/../basis-link/program/libsdlx.so + 0x1a91f4
0x3e72809f11: 0x626ee0: /usr/lib64/openoffice.org3/program/../basis-link/program/libsdlx.so + 0x409f11
0x3e7280a58b: 0x626ee0: /usr/lib64/openoffice.org3/program/../basis-link/program/libsdlx.so + 0x40a58b
0x3e728a1a83: 0x626ee0: /usr/lib64/openoffice.org3/program/../basis-link/program/libsdlx.so + 0x4a1a83
0x3e728ac6fa: 0x626ee0: /usr/lib64/openoffice.org3/program/../basis-link/program/libsdlx.so + 0x4ac6fa
0x3e728ac911: 0x626ee0: /usr/lib64/openoffice.org3/program/../basis-link/program/libsdlx.so + 0x4ac911
0x3e728ac9c9: 0x626ee0: /usr/lib64/openoffice.org3/program/../basis-link/program/libsdlx.so + 0x4ac9c9
0x3b724f4f73: 0x3f0dc8: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0xf4f73 (Timer::ImplTimerCallbackProc() + 0x83)
0x12954e: 0x55008: /usr/lib64/openoffice.org/basis3.0/program/libvclplug_gtklx.so + 0x1954e
0x3b6ce37f5b: 0xdf860: /lib64/libglib-2.0.so.0 + 0x37f5b
0x3b6ce3779b: 0xdf860: /lib64/libglib-2.0.so.0 + 0x3779b (g_main_context_dispatch + 0x23b)
0x3b6ce3af6d: 0xdf860: /lib64/libglib-2.0.so.0 + 0x3af6d
0x3b6ce3b12b: 0xdf860: /lib64/libglib-2.0.so.0 + 0x3b12b (g_main_context_iteration + 0x6b)
0x1293a5: 0x55008: /usr/lib64/openoffice.org/basis3.0/program/libvclplug_gtklx.so + 0x193a5
0x3b724f013e: 0x3f0dc8: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0xf013e (Application::Yield(bool) + 0x3e)
0x3b724f01b7: 0x3f0dc8: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0xf01b7 (Application::Execute() + 0x27)
0x3e71029269: 0x74938: /usr/lib64/openoffice.org3/program/../basis-link/program/libsofficeapp.so + 0x29269
0x3b724f4754: 0x3f0dc8: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0xf4754
0x3b724f47f5: 0x3f0dc8: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0xf47f5 (SVMain() + 0x25)
0x3e7105be4c: 0x74938: /usr/lib64/openoffice.org3/program/../basis-link/program/libsofficeapp.so + 0x5be4c (soffice_main + 0x9c)
0x40094b: 0x1028: /usr/lib64/openoffice.org3/program/simpress.bin + 0x94b (main + 0xb)
0x31ce01e576: 0x16bb40: /lib64/libc.so.6 + 0x1e576 (__libc_start_main + 0xe6)
0x400879: 0x1028: /usr/lib64/openoffice.org3/program/simpress.bin + 0x879
...end stackreport details ...
...start sample ldd details ...
	linux-vdso.so.1 =>  (0x00007fff5e9fe000)
	libgtk-x11-2.0.so.0 => /usr/lib64/libgtk-x11-2.0.so.0 (0x000000000012b000)
	libgdk-x11-2.0.so.0 => /usr/lib64/libgdk-x11-2.0.so.0 (0x0000000000a4f000)
	libatk-1.0.so.0 => /usr/lib64/libatk-1.0.so.0 (0x0000000000db6000)
	libgio-2.0.so.0 => /lib64/libgio-2.0.so.0 (0x0000000000fd6000)
	libpangoft2-1.0.so.0 => /usr/lib64/libpangoft2-1.0.so.0 (0x00000000c0606000)
	libgdk_pixbuf-2.0.so.0 => /usr/lib64/libgdk_pixbuf-2.0.so.0 (0x000000000124a000)
	libpangocairo-1.0.so.0 => /usr/lib64/libpangocairo-1.0.so.0 (0x0000000001467000)
	libcairo.so.2 => /usr/lib64/libcairo.so.2 (0x00000000e84a9000)
	libpango-1.0.so.0 => /usr/lib64/libpango-1.0.so.0 (0x0000000001672000)
	libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00000000018bb000)
	libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x0000000001b54000)
	libgmodule-2.0.so.0 => /lib64/libgmodule-2.0.so.0 (0x0000000001d85000)
	libgthread-2.0.so.0 => /lib64/libgthread-2.0.so.0 (0x0000000050a0a000)
	librt.so.1 => /lib64/librt.so.1 (0x0000000001f88000)
	libdbus-glib-1.so.2 => /usr/lib64/libdbus-glib-1.so.2 (0x0000000002191000)
	libdbus-1.so.3 => /lib64/libdbus-1.so.3 (0x00000000023b1000)
	libgobject-2.0.so.0 => /lib64/libgobject-2.0.so.0 (0x00000000025ef000)
	libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 (0x0000000002832000)
	libvclplug_genlx.so => /usr/lib64/openoffice.org/basis3.0/program/libvclplug_genlx.so (0x0000000002b13000)
	libvcllx.so => /usr/lib64/openoffice.org/basis3.0/program/libvcllx.so (0x0000000041084000)
	libpsplx.so => /usr/lib64/openoffice.org/basis3.0/program/libpsplx.so (0x0000000002da8000)
	libsotlx.so => /usr/lib64/openoffice.org/basis3.0/program/libsotlx.so (0x00000000030a0000)
	libutllx.so => /usr/lib64/openoffice.org/basis3.0/program/libutllx.so (0x0000000003304000)
	libtllx.so => /usr/lib64/openoffice.org/basis3.0/program/libtllx.so (0x000000000359f000)
	libcomphelp4gcc3.so => /usr/lib64/openoffice.org/basis3.0/program/libcomphelp4gcc3.so (0x000000000384e000)
	libucbhelper4gcc3.so => /usr/lib64/openoffice.org/basis3.0/program/libucbhelper4gcc3.so (0x0000000003ba3000)
	libuno_cppuhelpergcc3.so.3 => /usr/lib64/openoffice.org/basis3.0/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3 (0x0000000003e1f000)
	libuno_cppu.so.3 => /usr/lib64/openoffice.org/basis3.0/program/../ure-link/lib/libuno_cppu.so.3 (0x00000000b54fb000)
	libvos3gcc3.so => /usr/lib64/openoffice.org/basis3.0/program/libvos3gcc3.so (0x00000000040c9000)
	libuno_sal.so.3 => /usr/lib64/openoffice.org/basis3.0/program/../ure-link/lib/libuno_sal.so.3 (0x00000000042f0000)
	libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00000000046e7000)
	libX11.so.6 => /usr/lib64/libX11.so.6 (0x00000000048ee000)
	libXext.so.6 => /usr/lib64/libXext.so.6 (0x0000000004bf9000)
	libdl.so.2 => /lib64/libdl.so.2 (0x0000000004e0a000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00000000dcdb9000)
	libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x000000000500e000)
	libm.so.6 => /lib64/libm.so.6 (0x0000000005318000)
	libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00000000abfb7000)
	libc.so.6 => /lib64/libc.so.6 (0x000000000559d000)
	libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x000000000590f000)
	libXdamage.so.1 => /usr/lib64/libXdamage.so.1 (0x0000000005b11000)
	libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x0000000005d13000)
	libpng12.so.0 => /usr/lib64/libpng12.so.0 (0x0000000005f18000)
	libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00000000c360e000)
	libXinerama.so.1 => /usr/lib64/libXinerama.so.1 (0x000000000613d000)
	libXi.so.6 => /usr/lib64/libXi.so.6 (0x000000000633f000)
	libXcursor.so.1 => /usr/lib64/libXcursor.so.1 (0x0000000006548000)
	libselinux.so.1 => /lib64/libselinux.so.1 (0x0000000006752000)
	libpixman-1.so.0 => /usr/lib64/libpixman-1.so.0 (0x00000000f5e73000)
	libz.so.1 => /lib64/libz.so.1 (0x000000000696e000)
	libexpat.so.1 => /lib64/libexpat.so.1 (0x0000000006b83000)
	/lib64/ld-linux-x86-64.so.2 (0x00000031cdc00000)
	libnsl.so.1 => /lib64/libnsl.so.1 (0x0000000006dac000)
	libcap.so.2 => /lib64/libcap.so.2 (0x0000000006fc6000)
	libSM.so.6 => /usr/lib64/libSM.so.6 (0x00000000b2a7f000)
	libICE.so.6 => /usr/lib64/libICE.so.6 (0x00000000071ca000)
	libi18nisolang1gcc3.so => /usr/lib64/openoffice.org/basis3.0/program/libi18nisolang1gcc3.so (0x00000000073e5000)
	libbasegfxlx.so => /usr/lib64/openoffice.org/basis3.0/program/libbasegfxlx.so (0x00000000075ea000)
	libicuuc.so.40 => /usr/lib64/libicuuc.so.40 (0x0000000095854000)
	libicule.so.40 => /usr/lib64/libicule.so.40 (0x0000000007871000)
	libjvmaccessgcc3.so.3 => /usr/lib64/openoffice.org/basis3.0/program/../ure-link/lib/libjvmaccessgcc3.so.3 (0x0000000007aa6000)
	libuno_salhelpergcc3.so.3 => /usr/lib64/openoffice.org/basis3.0/program/../ure-link/lib/libuno_salhelpergcc3.so.3 (0x0000000007cad000)
	libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00000000ef129000)
	libxcb-xlib.so.0 => /usr/lib64/libxcb-xlib.so.0 (0x0000000007eb1000)
	libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00000000080b2000)
	libXau.so.6 => /usr/lib64/libXau.so.6 (0x00000000082cd000)
	libuuid.so.1 => /lib64/libuuid.so.1 (0x0000000037162000)
	libicudata.so.40 => /usr/lib64/libicudata.so.40 (0x00007f8855965000)
	libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00000000084cf000)
...end sample ldd details ...

Comment 1 Caolan McNamara 2009-02-09 10:58:09 UTC
Do you have a sample .ppt which caused this ? 

The stack would suggest that a final glyph fallback failed, i.e. some character in the .ppt which is unavailable in any installed font, but for some reason didn't just draw the "glyph not available" symbol and dived in disaster land

Comment 2 Trevor Spiteri 2009-02-09 21:08:33 UTC
Created attachment 331373 [details]
.ppt that causes crash

I can reproduce this bug by opening this file, and then dragging the scrollbar of the slide pane up and down rapidly and repeatedly. Sometimes it takes longer to crash, but in the end I can always manage to make it crsh.

Comment 3 David Tardon 2009-02-10 07:33:06 UTC
I'm not able to reproduce the crash. Could you run

yum list installed \*-fonts

in terminal and post the result here?

Comment 4 David Tardon 2009-02-10 08:50:51 UTC
*** Bug 484727 has been marked as a duplicate of this bug. ***

Comment 5 Trevor Spiteri 2009-02-10 09:13:53 UTC
$ yum list installed \*-fonts
Loaded plugins: refresh-packagekit
Installed Packages
VLGothic-fonts.noarch                       20081029-1.fc10            installed
abyssinica-fonts.noarch                     1.0-2.fc8                  installed
bitmap-fonts.noarch                         0.3-6.fc10                 installed
dejavu-fonts.noarch                         2.26-2.fc10                installed
ghostscript-fonts.noarch                    5.50-19.fc10               installed
jomolhari-fonts.noarch                      0.003-5.fc10               installed
kacst-fonts.noarch                          2.0-1.fc10                 installed
liberation-fonts.noarch                     1.04.92-1.fc10             installed
lklug-fonts.noarch                          0.2.2-6.fc10               installed
padauk-fonts.noarch                         2.4-2.fc10                 installed
paktype-fonts.noarch                        2.0-2.fc8                  installed
stix-fonts.noarch                           0.9-7.fc10                 installed
texlive-texmf-errata-fonts.noarch           2007-4.fc9                 installed
texlive-texmf-fonts.noarch                  2007-26.fc10               installed
urw-fonts.noarch                            2.4-6.fc10                 installed

Comment 6 David Tardon 2009-02-10 09:56:47 UTC
Reproduced after uninstalling most of the fonts. I have just those now:

ghostscript-fonts.noarch                     5.50-19.fc10              installed
liberation-fonts.noarch                      1.04.92-1.fc10            installed
texlive-texmf-errata-fonts.noarch            2007-4.fc9                installed
texlive-texmf-fonts.noarch                   2007-26.fc10              installed
urw-fonts.noarch                             2.4-6.fc10                installed

Do you have any substitution defined in Tools->Options->Openoffice.org/Fonts?

Comment 7 Trevor Spiteri 2009-02-10 10:37:59 UTC
I have no substitutions defined, and "Apply replacement table" is unchecked.

Comment 8 Caolan McNamara 2009-02-10 17:07:02 UTC
I think I see it, should be fixed in >= 3.0.1-15.3 (when built and made available)

Comment 9 Fedora Update System 2009-03-10 14:13:27 UTC
openoffice.org-3.0.1-15.3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/openoffice.org-3.0.1-15.3.fc10

Comment 10 Fedora Update System 2009-03-11 17:55:38 UTC
openoffice.org-3.0.1-15.3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2568

Comment 11 Fedora Update System 2009-03-16 19:38:29 UTC
openoffice.org-3.0.1-15.3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.