Bug 484615 - forcedeth device driver frees DMA memory with wrong function
forcedeth device driver frees DMA memory with wrong function
Status: CLOSED DUPLICATE of bug 484494
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-08 20:24 EST by Ellen Shull
Modified: 2009-02-09 10:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-09 10:54:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (160.82 KB, application/octet-stream)
2009-02-08 20:24 EST, Ellen Shull
no flags Details

  None (edit)
Description Ellen Shull 2009-02-08 20:24:00 EST
Created attachment 331264 [details]
/var/log/messages

Description of problem:
Feb  8 17:52:43 localhost kernel: ------------[ cut here ]------------
Feb  8 17:52:43 localhost kernel: WARNING: at lib/dma-debug.c:448 check_unmap+0x2b4/0x3dd() (Tainted: G        W )
Feb  8 17:52:43 localhost kernel: Hardware name: System Product Name
Feb  8 17:52:43 localhost kernel: forcedeth 0000:00:11.0: DMA-API: device driver frees DMA memory with wrong function [device address=0x0000000112d54000] [si
ze=21 bytes] [mapped as page] [unmapped as single]
Feb  8 17:52:43 localhost kernel: Modules linked in: bridge stp llc bnep sco l2cap bluetooth sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables
ipv6 cpufreq_ondemand powernow_k8 freq_table dm_multipath uinput snd_hda_codec_analog ppdev snd_hda_intel snd_hda_codec snd_hwdep snd_seq_dummy snd_seq_oss s
nd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer firewire_ohci snd firewire_core pcspkr soundcore aic7xxx snd_page_alloc
sata_sil24 forcedeth k8temp crc_itu_t scsi_transport_spi pata_amd parport_pc parport jedec_probe cfi_probe gen_probe cfi_util i2c_nforce2 mtd asus_atk0110 ch
ipreg i2c_core hwmon map_funcs ata_generic pata_acpi sata_nv raid456 async_xor async_memcpy async_tx xor raid1 sha256_generic cbc aes_x86_64 aes_generic dm_c
rypt ext4 jbd2 crc16 [last unloaded: scsi_wait_scan]
Feb  8 17:52:43 localhost kernel: Pid: 2721, comm: ssh Tainted: G        W  2.6.29-0.93.rc3.git10.fc11.x86_64 #1
Feb  8 17:52:43 localhost kernel: Call Trace:
Feb  8 17:52:43 localhost kernel: <IRQ>  [<ffffffff8104881a>] warn_slowpath+0xb7/0xe7
Feb  8 17:52:43 localhost kernel: [<ffffffff8137ba1f>] ? _spin_lock_irqsave+0x78/0x86
Feb  8 17:52:43 localhost kernel: [<ffffffff811983fb>] ? get_hash_bucket+0x28/0x34
Feb  8 17:52:43 localhost kernel: [<ffffffff8106a59a>] ? trace_hardirqs_off_caller+0x1f/0xac
Feb  8 17:52:43 localhost kernel: [<ffffffff81198a3f>] check_unmap+0x2b4/0x3dd
Feb  8 17:52:43 localhost kernel: [<ffffffff81198cb5>] debug_dma_unmap_page+0x50/0x52
Feb  8 17:52:43 localhost kernel: [<ffffffffa012b155>] T.799+0x66/0x6f [forcedeth]
Feb  8 17:52:43 localhost kernel: [<ffffffffa012b5e9>] nv_tx_done_optimized+0x44/0x1d0 [forcedeth]
Feb  8 17:52:43 localhost kernel: [<ffffffffa012bb09>] nv_nic_irq_optimized+0xb5/0x27b [forcedeth]
Feb  8 17:52:43 localhost kernel: [<ffffffff81093274>] handle_IRQ_event+0x22/0x5e
Feb  8 17:52:43 localhost kernel: [<ffffffff81094ab8>] handle_edge_irq+0xdb/0x124
Feb  8 17:52:43 localhost kernel: [<ffffffff81013a55>] do_IRQ+0xd4/0x14b
Feb  8 17:52:43 localhost kernel: [<ffffffff81011d93>] ret_from_intr+0x0/0x2e
Feb  8 17:52:43 localhost kernel: <EOI> <4>---[ end trace 0e6b3522a717e5d6 ]---

Version-Release number of selected component (if applicable):
2.6.29-0.93.rc3.git10.fc11.x86_64

How reproducible:
Seems to happen on first "serious" network access (dhcp doesn't trigger it) after every reboot.

Steps to Reproduce:
1.  use above kernel
2.  reboot
3.  access network (so far scp, yum update both 100%)
  
Actual results:
System seems to continue to work fine.  Have seen some other warning messages, not sure if they're related or general rawhideness.

Expected results:
No warning messages.

Additional info:
attaching full /var/log/messages in case other stuff in there is useful.

http://smolt.fedoraproject.org/show?uuid=pub_1d70c172-4c62-459a-95c2-d3ae3fa065bf
Comment 1 Richard W.M. Jones 2009-02-09 10:54:08 EST

*** This bug has been marked as a duplicate of bug 484494 ***

Note You need to log in before you can comment on or make changes to this bug.