Bug 48463 - Can not boot from scsi device because aic7xxx module dose not load
Can not boot from scsi device because aic7xxx module dose not load
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-10 14:36 EDT by Isaac Salsberg
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Isaac Salsberg 2001-07-10 14:36:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
I installed red-hat 7.1 on a scsi jazz drive, attahced to a VAIO lap-top 
using the Adaptec APA 1480 CardBus. The installation went just fine. 

I did not install lilo, so I generated a boot disk in order to boot linux. 
When I tried to boot, the system hangs saying:

Loading aic7xxx module
/lib/aic7xxx.o: init_module: No such Device
Hint: insmod errors ca be caused ...
ERROR: /bin/insmod exited abnormall!
VFS: Cannot open root device "sda2" or 08:02


How reproducible:
Always

Steps to Reproduce:
1. Insert boot disk
2. See messages
	

Additional info:
I used the following parameters at boot time, but did no work:
PCMCIA=yes iobase=0x140
Comment 1 Isaac Salsberg 2001-07-11 19:12:01 EDT
I finally could boot using a floppy disk, however the network card never worked.

I tried using the pcinitrd utility but it generates such a hugh image 
(initrd.img) that does not fit together with the vmlinuz file in the floppy,
so I found a workaround doing this:

# mkbootdisk 2.2.14-5.0
# cd /tmp
# mkdir qq
# mcopy a:initrd.img
# gunzip -c initrd.img > tempo
# mount -o loop -t ext2 tempo qq
# cd qq
# vi linuxrc, so it looks like this:


#!/bin/nash

echo "Loading pcmcia module"
insmod /lib/pcmcia/pcmcia_core.o
insmod /lib/pcmcia/yenta_socket.o
insmod /lib/pcmcia/ds.o
/bin/cardmgr
insmod /lib/pcmcia/cb_enabler.o
insmod /lib/pcmcia/pcnet_cs.o
echo "Loading scsi_mod module"
insmod /lib/scsi_mod.o
echo "Loading sd_mod module"
insmod /lib/sd_mod.o
echo "Loading aic7xxx module"
insmod /lib/aic7xxx.o
~
~
~
~
Afterwards:

# cd lib
# mkdir pcmcia
# cp <modules-path>/pcmcia/pcmcia_core.o pcmcia
# cp <modules-path>/pcmcia/yenta_socket.o pcmcia
# cp <modules-path>/pcmcia/ds.o pcmcia
# cp <module-path>/scsi/scsi_mod.o .
# cp <module-path>/scsi/sd_mod.o .
# cp <module-path>/scsi/aic7xxx.o  .

Then I copied the other files as th linuxrc file says.

# cd /tmp
# umount tempo
# gzip -c temp > initrd.img
# mcopy initrd.img a:

Then I used that floppy and boot linux.

The scsi modules and aic7xxx load just fine, however I could not loas 
cardmgr and the network card modules because they need other libraries that
do not fit into the floppy.

So, it was a partial solution. Still is necessary to startup the network card, 
but for that the pcinitr utility should be improved.
Comment 2 Bugzilla owner 2004-09-30 11:39:04 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.