Bug 48468 - makewhats in latest release of man conflicts with tmpwatch
makewhats in latest release of man conflicts with tmpwatch
Status: CLOSED DUPLICATE of bug 47784
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-10 14:54 EDT by mitchell mcgee
Modified: 2007-04-18 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-10 14:54:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mitchell mcgee 2001-07-10 14:54:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT; DigExt)

Description of problem:
man-1.5i2-0.7x appears to have introduced a version of makewhatis that 
creates a whatis file in /var/cache/man for Appache.  

How reproducible:
Always

Steps to Reproduce:
1.Occurs automatically if makewhatis.cron runs from cron (/etc/cron.daily 
or /etc/cron.weekly) and Appache exists on the system.
2.running /etc/cron.daily/tmpwatch
3.
	

Actual Results:  /usr/sbin/makewhatis is executed by the makewhatis.cron 
scripts in the /etc/cron.daily and /etc/cron.weekly 
directories.  /etc/cron.daily also contains the tmpwatch script.  The 
tmpwatch scripts checks to see if the /var/cache/man directory exists; if 
the directory exist, it assumes the directory /var/cache/man/X11R6/cat? 
directories also exist and attempts to pass these directories as 
parameters to /usr/sbin/tmpwatch.  The problem arises when the whatis file 
is the only entry in the /var/cache/man directory.  Then the following 
cron error is generated:
/etc/cron.daily/tmpwatch:
error: lstat() of directory /var/cache/man/X11R6/cat? failed: No such file 
or directory

The conflicting logic in /etc/cron.daily/tmpwatch is:
[-d /var/cache/man] && /usr/sbin/tmpwatch -f 240 /var/cache/man/
{X11R6/cat?, cat?, local/cat?}

Expected Results:  makewhatis should not place files under /var/cache/man 
or
/etc/cron.daily/tmpwatch script needs to condition the passing of 
directory paremters to /usr/sbin/tmpwatch upon a more specific check of 
the existence of directories /var/cache/man/X11R6, /var/cahce/man/cat?, 
and /var/cache/man/local/cat?.

Additional info:
Comment 1 Bernhard Rosenkraenzer 2001-07-11 06:00:43 EDT

*** This bug has been marked as a duplicate of 47784 ***

Note You need to log in before you can comment on or make changes to this bug.