Bug 484695 - Ctrl-<click> doesn't open source files
Ctrl-<click> doesn't open source files
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse-changelog (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Johnston
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-09 10:39 EST by Ben Konrath
Modified: 2010-01-05 10:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:51:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stack trace of IllegalArgumentException (2.31 KB, text/plain)
2009-02-09 10:39 EST, Ben Konrath
no flags Details

  None (edit)
Description Ben Konrath 2009-02-09 10:39:35 EST
Created attachment 331323 [details]
stack trace of IllegalArgumentException

Description of problem:

Shift-click doesn't open underlined source files in a ChangeLog file.

Version-Release number of selected component (if applicable):

eclipse-changelog-2.6.6-1.fc10.i386

How reproducible:

Always


Steps to Reproduce:
1. Check out this project:
http://svn.parabola.me.uk/mkgmap/trunk
2. Open the ChangeLog file.
3. Shift-click on the highlighted Java file in the first entry and see the attached exception.
  
Actual results:

There is an IllegalArgumentException printed to the console if you are running Fedora Eclipse with the -consolelog option and the source file doesn't open. See attached stack trace for details about the exception.

Expected results:

Source file should open.
Comment 1 Andrew Overholt 2009-02-09 10:48:59 EST
It's Ctrl-<click> and not Shift-<click>, right?
Comment 2 Ben Konrath 2009-02-09 10:54:26 EST
(In reply to comment #1)
> It's Ctrl-<click> and not Shift-<click>, right?

Yeah, sorry my mistake. It's Ctrl-<click> that doesn't work. I've updated the bug title.
Comment 3 Jeff Johnston 2009-02-09 15:22:30 EST
This is working for me.  I ran into an issue whereby I had to issue -clean when starting because the ChangeLog editor was having a problem with the editor descriptor.  After that, the editor runs fine and I was able to check out your project, open the ChangeLog, and use CTRL+CLICK on the first entry without problem.

This is what I have installed:

eclipse-rcp-3.4.1-5.fc10.i386
tomcat5-jasper-eclipse-5.5.27-6.1.fc10.noarch
eclipse-changelog-2.6.6-1.fc10.i386
eclipse-platform-3.4.1-5.fc10.i386
icu4j-eclipse-3.8.1-4.fc10.i386
eclipse-cdt-5.0.1-1.fc10.i386
eclipse-subclipse-1.2.4-12.fc10.noarch
eclipse-ecj-3.4.1-5.fc10.i386
eclipse-cdt-mylyn-5.0.1-1.fc10.i386
eclipse-pde-3.4.1-5.fc10.i386
eclipse-jdt-3.4.1-5.fc10.i386
eclipse-swt-3.4.1-5.fc10.i386
eclipse-mylyn-3.0.3-3.fc10.noarch
Comment 4 Ben Konrath 2009-02-09 16:26:35 EST
I'm still having the problem even when I run eclipse with '-clean'. Here's what I have installed:

rpm -qa | grep eclipse        
eclipse-ecj-3.4.1-5.fc10.i386
eclipse-platform-3.4.1-5.fc10.i386
eclipse-swt-3.4.1-5.fc10.i386
eclipse-subclipse-1.2.4-12.fc10.noarch
tomcat5-jasper-eclipse-5.5.27-6.1.fc10.noarch
eclipse-egit-0.4.0-1.fc10.noarch
icu4j-eclipse-3.8.1-4.fc10.i386
eclipse-rcp-3.4.1-5.fc10.i386
eclipse-jdt-3.4.1-5.fc10.i386
eclipse-pde-3.4.1-5.fc10.i386
eclipse-cdt-5.0.1-2.fc10.i386
eclipse-mylyn-3.0.3-3.fc10.noarch
eclipse-changelog-2.6.6-1.fc10.i386
eclipse-pydev-1.4.2-1.fc10.i386
Comment 5 Andrew Overholt 2009-02-09 17:20:27 EST
I think the problem is that the ChangeLog standards (loose, I'll admit) which were used as a basis for the editor don't take into account multiple files on the same line separated by commas as the ChangeLog does at your example project.

See:

http://www.gnu.org/software/emacs/manual/html_node/emacs/Format-of-ChangeLog.html
http://www.gnu.org/prep/standards/html_node/Change-Logs.html

Whether this should be supported or not is probably up for debate but we should move this bug to bugs.eclipse.org either way.  Would you mind doing this or should I?

Thanks.
Comment 6 Ben Konrath 2009-02-10 09:27:04 EST
Andrew, Thanks for the links and info, I'll file a bug about the Java files separated by commas upstream.

That said, I haven't yet solved the IllegalArgumentException problem. It turns out that the bug only happens when I use the git repository of mkgmap. Here are the updated instructions to reproduce the bug:

1. Check out git://github.com/burto/mkgmap.git
Note: The import function of the git plugin doesn't seem to work for me so I had to import the 'existing project into workspace' after I cloned the repository. Once the project was in my workspace, had to right-click on the project -> Team -> Share Project ... and select Git.

2. Create a new branch: <right-click> -> Team -> Branch .. -> new branch button -> enter branch name -> OK button -> select newly created branch -> click Checkout button  

3. Open the ChangeLog file.

4. Ctrl-<click> on the highlighted Java file in the first entry and see the
attached exception.
Comment 7 Bug Zapper 2009-11-18 06:03:49 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2009-12-18 02:51:53 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 9 Andrew Overholt 2010-01-05 10:15:59 EST
FWIW I just verified that the fixes Jeff applied for this issue upstream are present in Fedora 12.  I can Ctrl-<click> on the filenames in the mkgmap project's ChangeLog and have the files be opened.

Note You need to log in before you can comment on or make changes to this bug.