Bug 48470 - bad "Home" and "End" keys behaviour in gnome-terminal
Summary: bad "Home" and "End" keys behaviour in gnome-terminal
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-10 19:12 UTC by Leonid Kanter
Modified: 2007-03-27 03:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-23 21:33:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this patch solves the problem (2.71 KB, patch)
2001-08-10 19:01 UTC, Leonid Kanter
no flags Details | Diff

Description Leonid Kanter 2001-07-10 19:12:48 UTC
Description of Problem:

In gnome-terminal "Home" and "End" keys generate wrong esc-sequences

How Reproducible:

always

Steps to Reproduce:
1. start gnome-terminal
2. start mc
3. press "Home" or "End"

Actual Results:

You'll see "H" (for home key) and "F" (for End key) characters in command line.

Expected Results:

Pointer line must be moved to first or last file on the panel.

Additional Information:

In other terminals (konsole and xterm) home and end keys work as expected.

in xterm and konsole following sequences are generated: ^[[1~ (home) ^[[4~
(end). But gnome-terminal generates ^[OH for home and ^[OF for end keys.
TERM value is the same - xterm.

Comment 1 Havoc Pennington 2001-07-12 15:59:32 UTC
Sent upstream as http://bugzilla.gnome.org/show_bug.cgi?id=57437

Closing at Red Hat level.

Comment 2 Leonid Kanter 2001-08-10 19:01:26 UTC
Created attachment 27313 [details]
this patch solves the problem

Comment 3 Leonid Kanter 2001-08-10 19:07:36 UTC
This patch actualy does the same thing like kdebase-2.1-konsolefixes.patch from
kdebase package.

Here is changelog entry from kdebase:
* Fri Mar  9 2001 Preston Brown <pbrown@redhat.com>                            
- fix home and end default mapping in konsole

Why not do the same with gnome-libs? With this patch I'm quit happy with mc,
pine and other console stuff.

Comment 4 Havoc Pennington 2001-08-21 21:36:04 UTC
*** Bug 52241 has been marked as a duplicate of this bug. ***

Comment 5 Kjartan Maraas 2002-01-23 21:33:19 UTC
This has been fixed upstream.

Comment 6 Jay Turner 2002-02-13 20:39:37 UTC
Closing out.


Note You need to log in before you can comment on or make changes to this bug.