Bug 484719 - Bookmarks Toolbar menu drag'n'drop deadlock
Bookmarks Toolbar menu drag'n'drop deadlock
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
https://www.redhat.com/archives/fedor...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-09 11:45 EST by Michael Schwendt
Modified: 2009-02-10 15:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-10 15:17:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (6.72 KB, text/plain)
2009-02-09 11:45 EST, Michael Schwendt
no flags Details
screenshot of non-reproduction (77.74 KB, image/png)
2009-02-10 12:50 EST, Matěj Cepl
no flags Details
bt for all threads (12.48 KB, text/plain)
2009-02-10 14:17 EST, Michael Schwendt
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 470033 None None None Never

  None (edit)
Description Michael Schwendt 2009-02-09 11:45:17 EST
Created attachment 331332 [details]
backtrace

Description of problem:
Firefox locks up X/GNOME if I open the Bookmarks Toolbar menu (by clicking
the ">>" button at the very left) and then drag'n'drop a bookmark.


Version-Release number of selected component (if applicable):
$ rpm -q firefox xulrunner libxcb gtk2
firefox-3.0.6-1.fc10.i386
xulrunner-1.9.0.6-1.fc10.i386
libxcb-1.1.91-5.fc10.i386
gtk2-2.14.7-1.fc10.i386


How reproducible:
Always.

Steps to Reproduce:
1. Put enough bookmarks into the Bookmarks Toolbar folder, so that the ">>" button appears at the very right of the toolbar.
2. Click the ">>" button to open the pulldown menu that displays all bookmarks which don't fit into the toolbar.
3. Drag'n'drop a bookmark.
  
Actual results:
X and GNOME freeze except for mouse pointer movement. Keyboard input is not recognised anymore. Firefox consumes CPU power. One can still switch to a VC and kill Firefox, however.

Expected results:
Flawlessly drag'n'drop of bookmarks in Bookmarks Toolbar ">>" menu.
Comment 1 Matěj Cepl 2009-02-10 12:50:15 EST
Created attachment 331443 [details]
screenshot of non-reproduction

This is weird -- somehow I cannot reproduce this. When I overfill my Bookmark toolbar, I don't get >> button just some buttons don't show up (see attached screenshot).

Moreover -- your backtrace is not complete -- we need also the top of the backtrace where it says where the firefox actually broke, and I am not sure whether we have all threads (there is no crash itself there).

Could you provide more details about how you achieved this? Something interesting about your configuration, your network, your plugins (are you able to reproduce it with -safe-mode on the command line?), are you able to reproduce it with the upstream binary from mozilla.com?
Comment 2 Michael Schwendt 2009-02-10 14:17:34 EST
Created attachment 331452 [details]
bt for all threads

Here's a fresh backtrace for all threads.

> This is weird -- somehow I cannot reproduce this.

The user on fedora-list could. See URL.

> When I overfill my Bookmark toolbar, I don't get >> button

Then your system suffers from even a different problem. I notice the button for the Tabs pull-down menu is non-standard. Normally it's an arrow pointing down.

> we need also the top of the backtrace where it says where
> the firefox actually broke,

How? It locks up.
Comment 3 Michael Schwendt 2009-02-10 14:23:17 EST
Reproducible in safe-mode. Even when resetting everything except for the bookmarks.
Comment 4 Michael Schwendt 2009-02-10 15:17:47 EST
I'm closing this as WONTFIX, because of the following observation: It's a deficiency at the implementation level, a bug, but it won't be fixed in Fedora. Very unlikely.

I've made the mistake to try this on a second machine, got distracted and forgot to kill the firefox process. A couple of minutes later, it had moved the bookmark properly, ending the temporary freeze of X+GNOME+Firefox.

It's a terrible performance issue somewhere in Firefox. It takes minutes to move bookmarks the further down they appear in the bookmarks toolbar pulldown menu. Bookmarks near the top of the menu can be moved instantly. Bookmarks near position 10 of the menu are slower to move, delays become visible. Bookmarks at position 15 and further down take minutes. Processing time increases unproportionally.

Fortunately, the "Organize Bookmarks..." dialog does not suffer from such issues at all.

Other users will be able to reproduce this, not just the one on fedora-list. One can find reports with similar, albeit different symptoms:
https://bugzilla.mozilla.org/show_bug.cgi?id=470033 ("Bookmarks go into a seizure when adding new folder")

Note You need to log in before you can comment on or make changes to this bug.