Bug 484737 - KDE 4.2 Kickoff logout button shuts down the system
KDE 4.2 Kickoff logout button shuts down the system
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: kde42
  Show dependency treegraph
 
Reported: 2009-02-09 13:44 EST by Stan Trzmiel
Modified: 2009-02-10 12:44 EST (History)
8 users (show)

See Also:
Fixed In Version: 4.2.0-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-10 12:44:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 180576 None None None Never

  None (edit)
Description Stan Trzmiel 2009-02-09 13:44:43 EST
Description of problem:
Kickoff logout button shuts down the system instead of loggin out the user when confirmation box is disabled.


Version-Release number of selected component (if applicable):
kdebase-workspace-4.2.0-4.fc10.2.i386
kde-settings-kdm-4.1-6.20090206svn.fc10.noarch

How reproducible:
100%

Steps to Reproduce:
1. Disable Logout confirmation box (control center/advanced tab/session manager)
2. Try to logout using kickoff.
  
Actual results:
System shuts down


Expected results:
User session is over, system go back to login screen
Comment 1 Kevin Kofler 2009-02-09 13:49:24 EST
KDE 4.2 regression, marking as blocker.
Comment 2 Rex Dieter 2009-02-09 14:18:08 EST
Looks like this:
https://bugs.kde.org/show_bug.cgi?id=180576
Comment 3 Rex Dieter 2009-02-09 14:40:29 EST
OK, looks like we can try backporting the fix.

%changelog
* Mon Feb 09 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-8
- kickoff logout shuts down system (#484737, kdebug#180576)
Comment 4 Kevin Kofler 2009-02-10 12:44:37 EST
This will be fixed in the next push. KDE 4.1 not affected, closing.

Note You need to log in before you can comment on or make changes to this bug.