Bug 484739 - yum install [filename] can pick an old package and fail
yum install [filename] can pick an old package and fail
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-09 13:51 EST by Eric Paris
Modified: 2014-01-21 18:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-09 15:58:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Paris 2009-02-09 13:51:15 EST
assume foo-1.0 provides [filename] and is available in repo |A|

assume foo-2.0 does NOT provide [filename] but foo-bar-2.0 does.  Both are available in repo |B|

install foo-2.0.

If both repo |A| and |B| are enabled and you run yum install [filename] yum will choose to install foo-1.0 from repo |A| to satisfy your request.  yum then realizes that you have a newer version of foo already installed and does nothing.  This leaves you with yum thinking everything is good, but in reality it didn't install a package which provides [filename]

yum should find foo-bar in repo |B| and install that package to satisfy the request.
Comment 1 James Antill 2009-02-09 15:58:10 EST
 Ok, so if the obsoletes are there then "yum update /path/to/file" works atm. As the simple update will install foo-bar as well. However doing the update of just foo and not foo-bar, and then doing a "yum install /path/to/file" fails (it prefers the old foo over foo-bar, because a version of foo is installed). This is fixed in upstream commit:

b5bcc39f50bf7fa1d510a01182ee69b3366511cc

Note You need to log in before you can comment on or make changes to this bug.