Bug 484766 - crash during podcast download
crash during podcast download
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-09 15:14 EST by Christian Krause
Modified: 2009-03-12 19:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-12 19:56:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for banshee.spec (755 bytes, patch)
2009-02-09 15:15 EST, Christian Krause
no flags Details | Diff
patch to correct the timezone handling (3.04 KB, patch)
2009-02-09 15:16 EST, Christian Krause
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 570721 None None None Never

  None (edit)
Description Christian Krause 2009-02-09 15:14:31 EST
Description of problem:
I've discovered the following problem using banshee: During the download of a podcast banshee sometimes uses up to 100% CPU time and crashes after a couple of seconds. The reason is a recursive call of two functions (please see referenced gnome bug report).

The problem is not easy to trigger, because it is timezone-related (of the podcast as well as of the user). A detailed "how to reproduce" can be found in the gnome bug report.

Version-Release number of selected component (if applicable):
banshee-1.4.1-1.fc10.i386.rpm

How reproducible:
If the mentioned conditions are met then the problem is 100% reproducible (and very annoying). ;-)

Additional info:
The bug got already fixed in banshee's SVN (trunk). I've created a patch for F10  containing the same fix (besides the changelog entry) and a patch for banshee.spec.

It would be great if it could be applied to banshee in F10 as well!

Thank you very much in advance!
Comment 1 Christian Krause 2009-02-09 15:15:30 EST
Created attachment 331355 [details]
patch for banshee.spec
Comment 2 Christian Krause 2009-02-09 15:16:23 EST
Created attachment 331356 [details]
patch to correct the timezone handling
Comment 3 Michel Alexandre Salim 2009-02-10 09:22:40 EST
Thanks. I'm doing a test build now:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1117301

Could you confirm that the problem has disappeared, and also that it's still present in 1.4.2-1.fc10 that is in updates-testing?

(yum install banshee --enablerepo=updates-testing)

I'm currently on Rawhide, and some Mono GUI applications are currently not working there, so help testing is most welcome.
Comment 4 Christian Krause 2009-02-10 15:28:48 EST
(In reply to comment #3)
> Thanks. I'm doing a test build now:
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1117301

Thanks!

> Could you confirm that the problem has disappeared, and also that it's still
> present in 1.4.2-1.fc10 that is in updates-testing?
> 
> (yum install banshee --enablerepo=updates-testing)

I've just tested it: Yes, the problem is still present with banshee-1.4.2 from updates-testing.

Then I've installed the new test build from http://koji.fedoraproject.org/koji/taskinfo?taskID=1117304 and the problem was fixed.

> I'm currently on Rawhide, and some Mono GUI applications are currently not
> working there, so help testing is most welcome.

Sure, no problem!
Comment 5 Michel Alexandre Salim 2009-02-11 23:17:33 EST
Thanks for testing -- I'm building the new updates now. 1.4.2-1 has been in testing for long enough that it's probably better to land them in -stable first (they fix quite a few bugs), but I'm pushing this into testing once those land.
Comment 6 Christian Krause 2009-03-12 19:56:44 EDT
just doing some cleanup:

The problem was fixed when banshee-1.4.2-3.fc10.i386.rpm was pushed to stable. so I set the bug to CLOSED/NEXTRELEASE. Thanks again!

Note You need to log in before you can comment on or make changes to this bug.