Bug 484817 - kdump kernel fails to boot.
kdump kernel fails to boot.
Status: CLOSED DUPLICATE of bug 462519
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-09 21:05 EST by Wade Mealing
Modified: 2009-09-06 23:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-23 06:28:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of stuck location. (174.06 KB, image/jpeg)
2009-02-09 21:12 EST, Wade Mealing
no flags Details
Kdump.conf from system. (91 bytes, application/octet-stream)
2009-02-22 21:08 EST, Wade Mealing
no flags Details
sysconfig/kdump from system. (1.09 KB, application/octet-stream)
2009-02-22 21:08 EST, Wade Mealing
no flags Details

  None (edit)
Description Wade Mealing 2009-02-09 21:05:31 EST
Description of problem:

After having a panic, or by forcing one, the kdump kernel boots and is stuck after attempting to detect/classify memory.

After rebooting and building a new kdumprd, then rebooting again
       1: The kdump kernel doesn't start up if fibre is disconnected.
       2: Nor does it work if the fibre cards are unplugged.  
       3: Nor does it work if the ethernet cards are unplugged. 

System seems to hang at the same point in the boot, screenshot to be attached.

Version-Release number of selected component (if applicable):

initrd-2.6.18-120 with hotfix from bz470074

How reproducible:

Every time

Additional info:

Regular kernel seems to boot fine. Screenshot to be attached.  I dont have the kdump skills to debug this properly.
Comment 1 Wade Mealing 2009-02-09 21:12:20 EST
Created attachment 331387 [details]
Screenshot of stuck location.
Comment 2 Neil Horman 2009-02-10 06:20:05 EST
what is initrd-2.6.18-120?

What version of kexec and kernel are you running?  whats your kdump.conf look like?  what kind of system is this?  Can you attach a sysreport?
Comment 4 Wade Mealing 2009-02-22 21:08:01 EST
Created attachment 332890 [details]
Kdump.conf from system.

Kdump.conf from system.
Comment 5 Wade Mealing 2009-02-22 21:08:45 EST
Created attachment 332891 [details]
sysconfig/kdump from system.
Comment 6 Wade Mealing 2009-02-22 21:18:03 EST
Update:

The system seems to hang there, regardless of the state of the ethernet devices or the fiber connections. 

Kdump configs attached.
Comment 8 Neil Horman 2009-02-23 06:28:31 EST
This is a dupe of 462519, pretty clearly.

*** This bug has been marked as a duplicate of bug 462519 ***

Note You need to log in before you can comment on or make changes to this bug.