Bug 484822 - Trackpad not working due to misplaced comment in fdi file
Trackpad not working due to misplaced comment in fdi file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-02-09 22:56 EST by Will Woods
Modified: 2009-02-10 09:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-09 23:03:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixed fdi file (1.27 KB, text/plain)
2009-02-09 22:56 EST, Will Woods
no flags Details

  None (edit)
Description Will Woods 2009-02-09 22:56:04 EST
Created attachment 331388 [details]
fixed fdi file

After installing xorg-x11-drv-synaptics-1.0.0-3.fc11.i386, my touchpad stopped working and this message appeared in /var/log/messages:

Feb  9 21:27:20 localhost hald[2094]: error in fdi file /usr/share/hal/fdi/policy/20thirdparty/10-synaptics.fdi:6: XML or text declaration not at start of entity

This is due to the comment at the start of 10-synaptics.fdi. Apparently fdi files must start with the <?xml ...> tag.

Moving the comment after the <?xml version="1.0" encoding="ISO-8859-1"?> line fixes the problem.
Comment 1 Peter Hutterer 2009-02-09 23:03:28 EST
I was hoping that I fixed it before anyone got it but obviously I was too slow :)
Fixed with 1.0.0-4, sorry about the mess.

http://koji.fedoraproject.org/koji/buildinfo?buildID=82105

Note You need to log in before you can comment on or make changes to this bug.