Bug 484852 - Internal Server Error when getting details from a package that is not in any channel
Internal Server Error when getting details from a package that is not in any ...
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.4
All Linux
low Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Red Hat Satellite QA List
:
Depends On:
Blocks: space05
  Show dependency treegraph
 
Reported: 2009-02-10 05:45 EST by Santi Saez
Modified: 2009-09-17 03:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 03:10:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Santi Saez 2009-02-10 05:45:54 EST
I get a "Internal Server Error" in Spacewalk when:

Systems -> Software -> List / Remove -> Select a package

If selected package is not in any channel Spacewalk reports a "Internal Server Error" error.

Full catalina.out is available at:

http://pastebin.com/f377cd03a

And Apache log at:

http://pastebin.com/f44fc6551 

Using Spacewalk 0.4 + CentOS 5.2:

# rpm -qa spacewalk centos-release
spacewalk-0.4.2-3.el5
centos-release-5-2.el5.centos

Clifford Perry adds more info in the Spacewalk list [1]:

"The issue is that you have packages installed on a client system which do not have packages uploaded on the Spacewalk system. So you go look at the systems package profile, click on to select a specific package - this performs a DB lookup for more details. Sounds like we did not make a proper lookup on if we know details or not - get a Null (or empty data) and this results within the ISE. Other than uploading the package, no short term solution, or stop doing that - please file the bug and hopefully we can get it fixed."

[1] https://www.redhat.com/archives/spacewalk-list/2009-February/msg00192.html
Comment 1 Jesus M. Rodriguez 2009-03-26 00:00:05 EDT
fixed 9f17fb3f98a22685630be5b45ab3b32e9ae0720a

user taken to meaningful error pages instead of ISEs.
    Added a new Struts exception handler for NoSuchPackageException.
    Cleaned up PackageDetailsAction to handle errors and be better
    organized. PackageManager was not handling an empty DataResult which
    is a bad thing, now returns null which is handled by the caller.
    Added 2 negative tests for the changes made to PackageManager.
Comment 2 Jesus M. Rodriguez 2009-04-14 10:12:48 EDT
Spacewalk 0.5 released.
Comment 3 Miroslav Suchý 2009-09-17 03:10:07 EDT
Spacewalk 0.5 has been released for long time ago.

Note You need to log in before you can comment on or make changes to this bug.