Bug 484858 - java-openjdk i386 and x86_64 dualinstallation
Summary: java-openjdk i386 and x86_64 dualinstallation
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk
Version: 10
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lillian Angel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 487304 (view as bug list)
Depends On: 340391
Blocks: 497408
TreeView+ depends on / blocked
 
Reported: 2009-02-10 12:11 UTC by Patrick Steiner
Modified: 2009-09-15 14:40 UTC (History)
10 users (show)

(edit)
Clone Of:
: 590574 (view as bug list)
(edit)
Last Closed: 2009-09-15 07:44:51 UTC


Attachments (Terms of Use)

Description Patrick Steiner 2009-02-10 12:11:22 UTC
since the last java-openjdk (java-1.6.0-openjdk-devel-1.6.0.0-9.b14.fc10) update it is not possible to install the i386 and x86_64 version.

if get the following error:

Transaction Check Error:
  package java-1.6.0-openjdk-1:1.6.0.0-9.b14.fc10.x86_64 (which is newer than java-1.6.0-openjdk-1:1.6.0.0-2b12.fc10.i386) is already installed
  file /usr/share/doc/java-1.6.0-openjdk-1.6.0.0/ChangeLog from install of java-1.6.0-openjdk-1:1.6.0.0-2b12.fc10.i386 conflicts with file from package java-1.6.0-openjdk-1:1.6.0.0-9.b14.fc10.x86_64
  file /usr/share/doc/java-1.6.0-openjdk-1.6.0.0/NEWS from install of java-1.6.0-openjdk-1:1.6.0.0-2b12.fc10.i386 conflicts with file from package java-1.6.0-openjdk-1:1.6.0.0-9.b14.fc10.x86_64
  file /usr/share/doc/java-1.6.0-openjdk-1.6.0.0/README from install of java-1.6.0-openjdk-1:1.6.0.0-2b12.fc10.i386 conflicts with file from package java-1.6.0-openjdk-1:1.6.0.0-9.b14.fc10.x86_64

But i require both version because i use netbeans 6.5 with the mobility packet (WTK 2.5.2) and the midp-emulator requires the i386 version of the jdk.

with the previous version of java-openjdk als worked fine.

Comment 1 Matt Andrews 2009-02-11 04:03:51 UTC
I am also affected by this problem. as a temporary workarouns I was able to add the f10 i386 updates repo explicitly to yum and update from there.

here is the relevant stanza from /etc/yum.repos.d/fedora-updates.repo:

[updates-i386]
name=Fedora $releasever - i386 - Updates
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f$releasever&arch=i386
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-i386

and here is the yum command to install the i386 openjdk package.

# yum install --enablerepo=updates-i386 java-1.6.0-openjdk.i386

note that the i386 repo is disabled by default, and only enabled for installing the openjdk package.

Comment 2 Lillian Angel 2009-02-26 16:31:15 UTC
*** Bug 487304 has been marked as a duplicate of this bug. ***

Comment 3 Edouard Bourguignon 2009-05-04 15:53:53 UTC
Still impossible:

  package java-1.6.0-openjdk-1:1.6.0.0-15.b14.fc10.x86_64 (which is newer than java-1.6.0-openjdk-1:1.6.0.0-2b12.fc10.i386) is already installed
  file /usr/share/doc/java-1.6.0-openjdk-1.6.0.0/ChangeLog from install of java-1.6.0-openjdk-1:1.6.0.0-2b12.fc10.i386 conflicts with file from package java-1.6.0-openjdk-1:1.6.0.0-15.b14.fc10.x86_64
  file /usr/share/doc/java-1.6.0-openjdk-1.6.0.0/NEWS from install of java-1.6.0-openjdk-1:1.6.0.0-2b12.fc10.i386 conflicts with file from package java-1.6.0-openjdk-1:1.6.0.0-15.b14.fc10.x86_64
  file /usr/share/doc/java-1.6.0-openjdk-1.6.0.0/README from install of java-1.6.0-openjdk-1:1.6.0.0-2b12.fc10.i386 conflicts with file from package java-1.6.0-openjdk-1:1.6.0.0-15.b14.fc10.x86_64

too bad the package conflicts only with doc files.

Comment 4 Edward Rudd 2009-07-16 17:23:13 UTC
this is because you have two different version of openjdk.. If you install the SAME i386 release as the x86_64 release it works fine...

To do this you need to download the java-1.6.0-openjdk 15.b14.fc10 from the i386 repo and install both at the same time..

rpm -Uvh java-1.6.0-openjdk*386* java-1.6.0-openjdk*x86_64*



Now, what REALLY needs to happen is the i386 openjdk RPMS be available in the x86_64 repo so you don't have to access the 32bit repo.

As I run some x86_64 java stuff and some 32bit java stuff (ie eclipse, as it runs better).

Comment 5 Fedora Update System 2009-09-11 13:30:10 UTC
java-1.6.0-openjdk-1.6.0.0-21.b16.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-21.b16.fc10

Comment 6 Fedora Update System 2009-09-11 13:32:41 UTC
java-1.6.0-openjdk-1.6.0.0-29.b16.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-29.b16.fc11

Comment 7 Fedora Update System 2009-09-15 07:44:31 UTC
java-1.6.0-openjdk-1.6.0.0-21.b16.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2009-09-15 07:45:29 UTC
java-1.6.0-openjdk-1.6.0.0-29.b16.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.