Bug 484877 - sorting up undated packages by date is wrong and very annoying
sorting up undated packages by date is wrong and very annoying
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bodhi (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-10 08:34 EST by Alexei Podtelezhnikov
Modified: 2016-09-19 22:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-11 21:25:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexei Podtelezhnikov 2009-02-10 08:34:17 EST
I have been annoyed by this long enough to complain about it here.
Just look at this page: https://admin.fedoraproject.org/updates/F10/

Why do I need to see pages and pages of very old but undated packages before
I finally get to see what is really recent? How unprofessional! 

It is either web front-end should be more intelligent about sorting, or bodhi should be strict about the time data, or default to year 1969 to discipline the maintainers.
Comment 1 Luke Macken 2009-02-10 21:18:21 EST
This was caused by some bug during the updates push process that caused a batch or two of updates to go out without the date_released field.  This has happened in the past, and I've written code to to fix it.  I'll look into the cause of the problem and see if I can clean up this mess.  Thanks for the report.
Comment 2 Luke Macken 2009-02-10 21:36:36 EST
I fixed the updates with the missing timestamps.  It should hopefully look less "unprofessional".
Comment 3 Alexei Podtelezhnikov 2009-02-11 08:46:38 EST
"Stable" and "Pending" look beautiful now. I wonder why "Testing" is not fixed.
Thanks!
Comment 4 Luke Macken 2009-02-11 21:25:48 EST
Someone submitted a patch recently that shows pending updates that are on their way to testing in the main Testing list, which is why the top updates do not have a date pushed timestamp.

Note You need to log in before you can comment on or make changes to this bug.