Bug 484892 - sdiff does not recognize -E option
sdiff does not recognize -E option
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: diffutils (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Tim Waugh
Martin Kyral
:
Depends On:
Blocks: 914662 914666
  Show dependency treegraph
 
Reported: 2009-02-10 10:27 EST by Milos Malik
Modified: 2013-02-22 08:06 EST (History)
3 users (show)

See Also:
Fixed In Version: diffutils-2.8.1-16.el5
Doc Type: Bug Fix
Doc Text:
The -E option for the sdiff command was not accepted because of an accidental omission in the list of accepted options. This has now been fixed.
Story Points: ---
Clone Of:
: 914662 914666 (view as bug list)
Environment:
Last Closed: 2013-01-08 02:16:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diffutils-sdiff-E.patch (529 bytes, patch)
2009-02-13 12:36 EST, Tim Waugh
no flags Details | Diff

  None (edit)
Description Milos Malik 2009-02-10 10:27:26 EST
Description of problem:
The help message claims that "-E" option is recognized, but the utility does not know it.

Version-Release number of selected component (if applicable):
diffutils-2.8.1-15.2.3.el5

How reproducible:
always

Steps to Reproduce:
# sdiff --help | grep -- "-E"
  -E  --ignore-tab-expansion  Ignore changes due to tab expansion.
# sdiff -E
sdiff: invalid option -- E
sdiff: Try `sdiff --help' for more information.
# echo $?
2
# 
  
Actual results:
unrecognized option in help message

Expected results:
all options in help message are recognized

Additional info:
Comment 1 Milos Malik 2009-02-10 10:37:55 EST
# ./guess-options.sh -b /usr/bin/sdiff 
==== binary analysis -- enabled
==== The program recognizes 14 short options:
-B
-H
-I
-W
-a
-b
-d
-i
-l
-o
-s
-t
-v
-w
==== The program recognizes 18 long options:
--diff-program
--expand-tabs
--help
--ignore-all-space
--ignore-blank-lines
--ignore-case
--ignore-matching-lines
--ignore-space-change
--ignore-tab-expansion
--left-column
--minimal
--output
--speed-large-files
--strip-trailing-cr
--suppress-common-lines
--text
--version
--width
==== The program recognizes 14 equivalent options:
==== -B --ignore-blank-lines
==== -H --speed-large-files
==== -I --ignore-matching-lines
==== -W --ignore-all-space
==== -a --text
==== -b --ignore-space-change
==== -d --minimal
==== -i --ignore-case
==== -l --left-column
==== -o --output
==== -s --suppress-common-lines
==== -t --expand-tabs
==== -v --version
==== -w --width
==== The fake library issued following warnings:
==== -E is not processed by getopt_long()
# rpm -q diffutils
diffutils-2.8.1-15.2.3.el5.i386
#
Comment 2 Tim Waugh 2009-02-13 12:36:32 EST
Created attachment 331849 [details]
diffutils-sdiff-E.patch
Comment 3 RHEL Product and Program Management 2009-03-26 12:47:21 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 11 Tim Waugh 2012-06-15 12:15:23 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The -E option for the sdiff command was not accepted because of an accidental omission in the list of accepted options. This has now been fixed.
Comment 15 errata-xmlrpc 2013-01-08 02:16:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0036.html

Note You need to log in before you can comment on or make changes to this bug.