Bug 484908 - Unresolvable chain of dependencies for openmpi-libs 1.2.8-3.el4
Summary: Unresolvable chain of dependencies for openmpi-libs 1.2.8-3.el4
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openmpi
Version: 4.8
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Doug Ledford
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: RHEL4u8_relnotes 494022
TreeView+ depends on / blocked
 
Reported: 2009-02-10 17:08 UTC by Alexander Todorov
Modified: 2009-05-07 22:36 UTC (History)
15 users (show)

(edit)
Updating all packages from Red Hat Enterprise Linux 4.7 to Red Hat Enterprise
Linux 4.8 on multilib architectures may fail with dependency issues for the
openmpi-libs package. To work around this issue, use the following commands to
update the compat-dapl package before updating the remaining packages.

up2date compat-dapl
up2date -fu
Clone Of:
: 494022 (view as bug list)
(edit)
Last Closed: 2009-05-06 14:32:32 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2009:1023 normal SHIPPED_LIVE openmpi and mvapich bug fix and enhancement update 2009-05-18 14:47:19 UTC

Description Alexander Todorov 2009-02-10 17:08:09 UTC
Description of problem:
running up2date -fu against rhn.webqa on @everything RHEL4-U7 system yields:

Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
openmpi-libs  1.2.8-3.el4                requires libdat.so.1
openmpi-libs  1.2.8-3.el4                requires libdat.so.1(DAT_1.2)


Version-Release number of selected component (if applicable):
openmpi-libs-1.2.8-3.el4

How reproducible:
Always on x86_64

Steps to Reproduce:
1. Install RHEL4.7, @everything
2. Subscribe the system to RHN instance (all beta channels)
3. Run up2date -fu
  
Actual results:
Update fails. 

Expected results:
Update succeeds.

Additional info:
1.2.8-3 is the version in the BETA channels from latest 4.8 build. The installed version in RHEL4-U7 is openmpi-libs-1.2.5-5.el4. Both 32 and 64bit packages are installed.

Comment 1 Alexander Todorov 2009-02-10 17:20:54 UTC
Similar thing on ppc. This time the 64bit package seems to fail:


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
openmpi-libs  1.2.8-3.el4                requires libdat.so.1()(64bit)
openmpi-libs  1.2.8-3.el4                requires libdat.so.1(DAT_1.2)(64bit)


The following packages were added to your selection to satisfy dependencies:
Package                                Required by
----------------------------------------------------------------------------

Comment 2 Doug Ledford 2009-02-10 17:32:38 UTC
In both cases, the missing libraries are provided by the compat-dapl packages.  Sounds to me like those packages didn't make it into the multilib setup or something like that.  I'll ping rel-eng about it.

Comment 4 Ben Levenson 2009-02-12 16:53:08 UTC
# rpm -qp --requires /mnt/redhat/rel-eng/RHEL4-U8-re20090128.1/repo-AS-x86_64/RPMS/openmpi-libs-1.2.8-3.el4.x86_64.rpm| grep libdat
libdat.so.1()(64bit)  
libdat.so.1(DAT_1.2)(64bit)  

# rpm -qp --provides /mnt/redhat/rel-eng/RHEL4-U8-re20090128.1/repo-AS-x86_64/RPMS/compat-dapl-2*x86_64*| grep libdat
libdat.so.1()(64bit)  
libdat.so.1(DAT_1.2)(64bit)  


Looks like all of the correct bits are in the compose. 
Alexander, Perhaps there is something wrong with the beta repo you are using??

Comment 7 Alexander Todorov 2009-02-17 11:41:07 UTC
I'm seeing the same issue with ppc and x86_64 with latest build. However here are some findings:

x86_64:

running up2date -fu yields:

openmpi-libs  1.2.8-3.el4                requires libdat.so.1
openmpi-libs  1.2.8-3.el4                requires libdat.so.1(DAT_1.2)

# rpm -qa | grep compat-dapl
compat-dapl-1.2.5-2.0.7-2.el4
compat-dapl-static-1.2.5-2.0.7-2.el4
compat-dapl-devel-1.2.5-2.0.7-2.el4

# rpm -q --qf "%{name}-%{epoch}:%{version}-%{release}.%{arch}\n" compat-dapl-1.2.5
compat-dapl-1.2.5-(none):2.0.7-2.el4.x86_64

This is already installed and present on the system. Notice that the name is "compat-dapl-1.2.5" where "2.0.7" is the version.

# up2date install compat-dapl installs compat-dapl-2.0.15-1.el4.x86_64.rpm and removed compat-dapl-1.2.5.

As a result from the above the 32bit compat-dapl is pulled into the transaction and up2date -fu is able to proceed to updating the packages.

Comment 11 Alexander Todorov 2009-02-17 15:17:59 UTC
I can work around this issue by executing:
# up2date compat-dapl && up2date -fu

Should we add a release note?

Comment 13 Ludek Smid 2009-02-23 21:35:13 UTC
Release note for RHEL 4.8 beta is needed.

Comment 14 Alexander Todorov 2009-02-24 09:13:51 UTC
Added Ryan to CC and sample release note text into Release Notes field. Please edit if necessary.

Comment 15 Alexander Todorov 2009-02-24 09:13:51 UTC
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
When updating all packages on RHEL4-U7 to RHEL4-U8 the transaction could fail with unresolvable chain of dependencies for openmpi-libs. This is usually seen on multilib architectures. To work around this issue update the compat-dapl package first and then the rest of the system. Use a command sequence like this:

# up2date compat-dapl
# up2date -fu

Comment 20 Ryan Lerch 2009-03-15 22:40:49 UTC
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,4 +1,4 @@
-When updating all packages on RHEL4-U7 to RHEL4-U8 the transaction could fail with unresolvable chain of dependencies for openmpi-libs. This is usually seen on multilib architectures. To work around this issue update the compat-dapl package first and then the rest of the system. Use a command sequence like this:
+Updating all packages from Red Hat Enterprise Linux 4.7 to Red Hat Enterprise Linux 4.8 on multilib architectures may fail with dependency issues for the openmpi-libs package. To work around this issue, use the following commands to update the compat-dapl package before updating the remaining packages.
 
-# up2date compat-dapl
+up2date compat-dapl
-# up2date -fu+up2date -fu

Comment 26 Doug Ledford 2009-04-14 15:25:42 UTC
Deleted Release Notes Contents.

Old Contents:
Updating all packages from Red Hat Enterprise Linux 4.7 to Red Hat Enterprise Linux 4.8 on multilib architectures may fail with dependency issues for the openmpi-libs package. To work around this issue, use the following commands to update the compat-dapl package before updating the remaining packages.

up2date compat-dapl
up2date -fu

Comment 52 Ludek Smid 2009-05-06 14:09:17 UTC
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Updating all packages from Red Hat Enterprise Linux 4.7 to Red Hat Enterprise
Linux 4.8 on multilib architectures may fail with dependency issues for the
openmpi-libs package. To work around this issue, use the following commands to
update the compat-dapl package before updating the remaining packages.

up2date compat-dapl
up2date -fu

Comment 53 Ben Levenson 2009-05-06 14:32:32 UTC
marking as CLOSED:WONTFIX. The issue with up2date is being tracked in bug 494022


Note You need to log in before you can comment on or make changes to this bug.