Bug 484912 - geeqie crashes if entering a directory whos content is changing
geeqie crashes if entering a directory whos content is changing
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: geeqie (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael Schwendt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-10 12:52 EST by Pontus Enhager
Modified: 2009-03-27 10:52 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.0-0.14.alpha3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-27 10:52:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash report from bug-buddy (14.33 KB, text/plain)
2009-02-10 12:52 EST, Pontus Enhager
no flags Details
stacktrace (8.81 KB, text/plain)
2009-02-10 16:48 EST, Pontus Enhager
no flags Details

  None (edit)
Description Pontus Enhager 2009-02-10 12:52:02 EST
Created attachment 331444 [details]
crash report from bug-buddy

Description of problem:
geeqie crashes when entering a directory in which files simultaneously are added (i.e. other process is adding files to the chosen directory) 

Version-Release number of selected component (if applicable):
[pontus@selleri ~]$ rpm -q geeqie
geeqie-1.0-0.8.alpha2.fc10.x86_64


How reproducible:
95% of the times

Steps to Reproduce:
1.start copying (a lot of) files into the foo directory
2. start geeqie while moving files
3. enter the foo directory
  
Actual results:
crash

Expected results:
viewing images , and the index is updated along the way

Additional info:
(i run into this when importing pictures from my digicam and being too curious to wait until import process ends - still the application should not crash!
Comment 1 Michael Schwendt 2009-02-10 14:00:17 EST
Before I get a chance to try to reproduce it, can you get a backtrace, please?
http://fedoraproject.org/wiki/StackTraces
Comment 2 Michael Schwendt 2009-02-10 16:13:33 EST
Preparing a test update:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1118036
Comment 3 Pontus Enhager 2009-02-10 16:48:28 EST
Created attachment 331478 [details]
stacktrace

is this enough ? gdb named a massive amount of debug packages that were not installed - i might get back at installing some of them tomorrow morning and trying again

brg Pontus
Comment 4 Michael Schwendt 2009-02-11 02:49:03 EST
Thanks. You had already included a useful backtrace at the very top of your original report. I've simply missed it when skimming over new bz mails. I think the issue is fixed in the mentioned build that will show up in the updates-testing repo eventually.
Comment 5 Michael Schwendt 2009-02-13 15:26:55 EST
https://admin.fedoraproject.org/updates/F10/FEDORA-2009-1599
(as why bodhi has not announced this here, dunno)
Comment 6 Fedora Update System 2009-02-26 02:49:47 EST
geeqie-1.0-0.14.alpha3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/geeqie-1.0-0.14.alpha3.fc10
Comment 7 Fedora Update System 2009-02-26 10:34:47 EST
geeqie-1.0-0.14.alpha3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update geeqie'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2129
Comment 8 Fedora Update System 2009-03-27 10:52:35 EDT
geeqie-1.0-0.14.alpha3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.