Bug 484915 - System-config-services does not work on FC10
System-config-services does not work on FC10
Status: CLOSED DUPLICATE of bug 467871
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-10 13:05 EST by ea6825
Modified: 2009-02-17 06:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-17 06:34:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ea6825 2009-02-10 13:05:35 EST
system-config-services-0.99.28-3.fc10.noarch.rpm that is contained in FC10 initialzes when started with the GUI entirely "disabled" (greyed) except for the HELP menu item which is "enabled".  I have tried to uninstall it and reinstall. That process goes smoothly but does not have any effect. I notice that the GUI does build a list of services but they display in the GUI as "disabled" and greyed.  I have tried to uninstall and install an older version (system-config-services-0.99.28-1.fc10.noarch.rpm) but it works the same.  



How reproducible: Every time the program is activated via the GNOME desktop or command line.


Steps to Reproduce:
1. System/Administration/Services or 
2. Command line:  system-config-services

  
Actual results:  GUI starts up and builds a list of services but all are greyed and not selectable.  The Cursor shows the program is "busy" and hangs in that state requiring that the window be terminated. No opportunity to enter the authentication password occurs


Expected results: The GUI starts up and builds a list of services that become "enabled" (change from greyed to normal color) when the list is completely built by the program.  When the program changes the services list from grey the entries are then selectable and can operate the respective service through the GUI. Authentication password is prompted by the program prior to "enable" of the GUI by the program.


Additional info:  This worked fine under FC9 but does not work after the upgrade to FC10.  When invoked on the command-line the program has to be cancelled off since it hangs, hence the keyboardInterrupt. Here are the system messages when invoked via the command line:

/usr/sbin/system-config-services:580: GtkWarning: gtk_tree_view_scroll_to_cell: assertion `tree_view->priv->model != NULL' failed
  self.servicesTreeView.scroll_to_cell (path)
/usr/lib/python2.5/site-packages/scservices/core/services.py:436: DeprecationWarning: raising a string exception is deprecated
  raise output
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/scservices/core/asynccmd.py", line 96, in on_fd
    self._finish ()
  File "/usr/lib/python2.5/site-packages/scservices/core/asynccmd.py", line 108, in _finish
    self.ready_cb (self, *self.ready_args, **self.ready_kwargs)
  File "/usr/lib/python2.5/site-packages/scservices/core/asynccmd.py", line 153, in _ready_cb
    ready_cb (cmd, *p, **k)
  File "/usr/lib/python2.5/site-packages/scservices/core/services.py", line 101, in _async_load_ready
    self._async_load_process (cmd)
  File "/usr/lib/python2.5/site-packages/scservices/core/services.py", line 436, in _async_load_process
    raise output
pure-ftpd      	0:off	1:off	2:off	3:off	4:off	5:off	6:off

^CTraceback (most recent call last):
  File "/usr/lib64/python2.5/site-packages/gamin.py", line 107, in _internal_callback
    self.callback (path, event, self.data)
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 61, in on_dir_changed
    self.on_dir_changed (path, action, dir)
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 284, in on_dir_changed
    self.create_service_delayed (path)
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 295, in create_service_delayed
    self.create_service_cb (name)
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 302, in create_service_cb
    self.create_service (name)
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 113, in create_service
    serviceobj = self.service_class (name, self.mon, self)
  File "/usr/lib/python2.5/site-packages/scservices/core/services.py", line 408, in __init__
    self.load ()
  File "/usr/lib/python2.5/site-packages/scservices/core/services.py", line 82, in load
    mainloop.run ()
KeyboardInterrupt
/usr/sbin/system-config-services:677: GtkWarning: gtk_tree_selection_select_iter: assertion `selection->tree_view != NULL' failed
  self.servicesTreeView.selection.select_iter (iter)
Traceback (most recent call last):
  File "/usr/lib64/python2.5/site-packages/gamin.py", line 107, in _internal_callback
    self.callback (path, event, self.data)
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 61, in on_dir_changed
    self.on_dir_changed (path, action, dir)
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 275, in on_dir_changed
    self.set_ready ()
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 267, in set_ready
    super (XinetdServiceHerder, self).set_ready ()
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 98, in set_ready
    self.notify (SVC_HERDER_READY)
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 149, in notify
    change = change, *subscriber.p, **k)
  File "/usr/sbin/system-config-services", line 557, in on_services_changed
    self.on_service_herder_ready (herder)
  File "/usr/sbin/system-config-services", line 666, in on_service_herder_ready
    self.enable ()
  File "/usr/sbin/system-config-services", line 680, in enable
    self.mainWindow.window.set_cursor (None)
AttributeError: 'NoneType' object has no attribute 'set_cursor'
Comment 1 Stefan Jensen 2009-02-10 17:59:29 EST
Hi,...

same for me here with "system-config-services-0.99.28-3.fc10.noarch"

Starting from console brings up the system-config-services window, but end up with not functional "grayed out" window. Hitting <STRG+C> in the console window then, bring back the functionality.

These errors where printed out on the console:

sudo system-config-services 
/usr/lib/python2.5/site-packages/scservices/core/services.py:436: DeprecationWarning: raising a string exception is deprecated
  raise output
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/scservices/core/asynccmd.py", line 96, in on_fd
    self._finish ()
  File "/usr/lib/python2.5/site-packages/scservices/core/asynccmd.py", line 108, in _finish
    self.ready_cb (self, *self.ready_args, **self.ready_kwargs)
  File "/usr/lib/python2.5/site-packages/scservices/core/asynccmd.py", line 153, in _ready_cb
    ready_cb (cmd, *p, **k)
  File "/usr/lib/python2.5/site-packages/scservices/core/services.py", line 101, in _async_load_ready
    self._async_load_process (cmd)
  File "/usr/lib/python2.5/site-packages/scservices/core/services.py", line 436, in _async_load_process
    raise output
oidentd        	0:off	1:off	2:off	3:off	4:off	5:off	6:off

^CTraceback (most recent call last):
  File "/usr/lib64/python2.5/site-packages/gamin.py", line 107, in _internal_callback
    self.callback (path, event, self.data)
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 61, in on_dir_changed
    self.on_dir_changed (path, action, dir)
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 284, in on_dir_changed
    self.create_service_delayed (path)
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 295, in create_service_delayed
    self.create_service_cb (name)
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 302, in create_service_cb
    self.create_service (name)
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 113, in create_service
    serviceobj = self.service_class (name, self.mon, self)
  File "/usr/lib/python2.5/site-packages/scservices/core/services.py", line 408, in __init__
    self.load ()
  File "/usr/lib/python2.5/site-packages/scservices/core/services.py", line 82, in load
    mainloop.run ()
KeyboardInterrupt
Comment 2 Nils Philippsen 2009-02-16 06:10:08 EST
Most of the tracebacks are due to killing off the program with Ctrl+C.

Is the following error happening before or after you pressed Ctrl+C?

/usr/sbin/system-config-services:580: GtkWarning: gtk_tree_view_scroll_to_cell:
assertion `tree_view->priv->model != NULL' failed
  self.servicesTreeView.scroll_to_cell (path)
/usr/lib/python2.5/site-packages/scservices/core/services.py:436:
DeprecationWarning: raising a string exception is deprecated
  raise output
Comment 3 ea6825 2009-02-16 13:02:30 EST
This is what I get when I invoke "system-config-services" from the command line today.  I have gotten some system updates since I reported this problem. I did not do a "CTRL-C" to get this.  When I cancel the program by either a "CTRL-C" on the command line or "X"ed the GUI to kill it, I get no additional messages from the system.  I got this on the initial start of the program after a boot-up. I noticed that I do not get anything in the way of messages after I start the program after that.  I notice that there is a difference in the way that the programs starts up initially after a "boot" -- the GUI shows that the program builds a greyed-out list of services.  Upon starting the program again (a second, third, etc. time) the list does not build but is just redisplayed in the greyed-out fashion.  What is common in the attempts to run the program is that the list of services stays greyed and the cursor is animated showing the program is busy.

[ea6825@Iceman ~]$ system-config-services
ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/scservices/dbus/proxy/serviceherders.py", line 123, in notify
    self.dbus_notify (subscriber, service_name, change)
  File "/usr/lib/python2.5/site-packages/scservices/dbus/proxy/serviceherders.py", line 92, in dbus_notify
    service = self.services[service_name]
KeyError: dbus.String(u'clamd.exim')
ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/scservices/dbus/proxy/serviceherders.py", line 123, in notify
    self.dbus_notify (subscriber, service_name, change)
  File "/usr/lib/python2.5/site-packages/scservices/dbus/proxy/serviceherders.py", line 92, in dbus_notify
    service = self.services[service_name]
KeyError: dbus.String(u'clamd.exim')
ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/scservices/dbus/proxy/serviceherders.py", line 123, in notify
    self.dbus_notify (subscriber, service_name, change)
  File "/usr/lib/python2.5/site-packages/scservices/dbus/proxy/serviceherders.py", line 92, in dbus_notify
    service = self.services[service_name]
KeyError: dbus.String(u'clamd.exim')
ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/scservices/dbus/proxy/serviceherders.py", line 123, in notify
    self.dbus_notify (subscriber, service_name, change)
  File "/usr/lib/python2.5/site-packages/scservices/dbus/proxy/serviceherders.py", line 92, in dbus_notify
    service = self.services[service_name]
KeyError: dbus.String(u'clamd.exim')
Comment 4 ea6825 2009-02-16 14:18:34 EST
This is a revision of the my response a few minutes ago.  I notice these things.

1) when I invoke the program on the command line with "sudo" it automatically responds with these messages and "hangs" the command line:

sudo system-config-services
/usr/lib/python2.5/site-packages/scservices/core/services.py:436: DeprecationWarning: raising a string exception is deprecated
  raise output
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/scservices/core/asynccmd.py", line 96, in on_fd
    self._finish ()
  File "/usr/lib/python2.5/site-packages/scservices/core/asynccmd.py", line 108, in _finish
    self.ready_cb (self, *self.ready_args, **self.ready_kwargs)
  File "/usr/lib/python2.5/site-packages/scservices/core/asynccmd.py", line 153, in _ready_cb
    ready_cb (cmd, *p, **k)
  File "/usr/lib/python2.5/site-packages/scservices/core/services.py", line 101, in _async_load_ready
    self._async_load_process (cmd)
  File "/usr/lib/python2.5/site-packages/scservices/core/services.py", line 436, in _async_load_process
    raise output
pure-ftpd      	0:off	1:off	2:off	3:off	4:off	5:off	6:off

2) When I "CTRL-C" at the this point to get control back, I notice that the GUI "enables" the greyed-out list of services and the GUI is functional and I get these messages on the command line:

^CTraceback (most recent call last):
  File "/usr/lib64/python2.5/site-packages/gamin.py", line 107, in _internal_callback
    self.callback (path, event, self.data)
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 61, in on_dir_changed
    self.on_dir_changed (path, action, dir)
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 284, in on_dir_changed
    self.create_service_delayed (path)
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 295, in create_service_delayed
    self.create_service_cb (name)
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 302, in create_service_cb
    self.create_service (name)
  File "/usr/lib/python2.5/site-packages/scservices/core/serviceherders.py", line 113, in create_service
    serviceobj = self.service_class (name, self.mon, self)
  File "/usr/lib/python2.5/site-packages/scservices/core/services.py", line 408, in __init__
    self.load ()
  File "/usr/lib/python2.5/site-packages/scservices/core/services.py", line 82, in load
    mainloop.run ()
KeyboardInterrupt

3) The programs runs satisfactorily until I cancel it at the command line with a "CTRL-C" or via the GUI.

4) The program is not functional in any other scenario, e.g. running from the GNOME desktop (system/administration/services), ordinary user at the command line, or in a "su" shell at the command line.  It can only be "tricked" up to work by using the "sudo" command and then you give a "CTRL-C" when the GUI completely builds the greyed-out list of services. 

I hope this is useful.  I miss my functional system-config-services command that I had with FC9.  At least I have discovered a work-around. Good Luck.
Comment 5 Nils Philippsen 2009-02-17 06:34:14 EST

*** This bug has been marked as a duplicate of bug 467871 ***

Note You need to log in before you can comment on or make changes to this bug.