Bug 484937 - Regression in displaying UTF-8 characters in GTK+ 1.2.10 widgets
Regression in displaying UTF-8 characters in GTK+ 1.2.10 widgets
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gtk+ (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-10 13:58 EST by Zoltan Boszormenyi
Modified: 2009-02-10 15:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-10 15:55:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zoltan Boszormenyi 2009-02-10 13:58:36 EST
Description of problem:

Applications compiled for GTK+ 1.2 and/or gnome-libs-1.4.2 no longer display UTF-8 characters properly on Fedora 10. The same application (compiled on Fedora Core 6) runs fine on Fedora Core 6 and Fedora 9. LANG=hu_HU.UTF-8

Version-Release number of selected component (if applicable):

gtk+-1.2.10-66.fc10.i386
gnome-libs-1.4.2-10.fc10.i386

How reproducible:

Always.

Steps to Reproduce:
1. Install Fedora 10
2. Run a GTK1 app that uses some non-ASCII UTF-8 chars in widgets
3. 
  
Actual results:

Non-ASCII characters display as some gibberish, i.e. like the UTF-8 chars and input (e.g. in a GTK_ENTRY) is interpreted as Latin1/Latin2.

Expected results:

Display every characters correctly.

Additional info:

I compiled glade-0.6.4-10 from an older Fedora system and it behaves the same, i.e. i18n correctly picks up Hungarian, but widgets (labels, menus, etc) display gibberish. The UTF-8 input seems to work and kept intact, because when I create a new window and set its label then the WM shows the correct text in the window caption.
Comment 1 Zoltan Boszormenyi 2009-02-10 15:55:25 EST
The above was experienced with a freshly installed but then fully upgraded
F10 system. I remembered seeing something similar on earlier Fedora systems,
specifically on F8 that was later upgraded to F9, so all packages were kept
during the upgrade. On that system installing all fonts by "yum install *fonts*"
solved it. I tried installing all fonts on this F10 system and the problem
disappeared as well. I don't know specifically which font solved it.
Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.