Bug 484978 - Only schedule tests required for the correct type of machine in HTS
Only schedule tests required for the correct type of machine in HTS
Status: CLOSED DUPLICATE of bug 485837
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5.3
All Linux
high Severity high
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-10 17:47 EST by Gary Case
Modified: 2014-03-25 20:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-10 14:42:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Case 2009-02-10 17:47:46 EST
Description of problem:
In its current state, HTS will schedule tests for all components it detects when you issue 'hts plan'. This is desirable on the base system, but causes problems for FV guests. Specifically, guests can have CDROM, VIDEO and PROFILER tests scheduled, even though these are not required for FV guest testing. The harness should be able to detect what type of system it's running on and schedule accordingly. 

Version-Release number of selected component (if applicable):
5.3-15

How reproducible:
Every time

Steps to Reproduce:
1. Install FV guest
2. Run "hts plan"
3. Unneeded tests are scheduled
  
Actual results:
Unneeded tests that can cause failures.

Expected results:
Exact amount of tests needed.

Additional info:
Comment 1 Rob Landry 2009-05-12 14:52:35 EDT
Is this resolved by the hts-5.3-17 errata?
Comment 2 Issue Tracker 2009-05-12 16:30:21 EDT
I just checked the latest version of hts, hts-5.3-17, and it no longer
schedules the profiler test on Xen guests. Please give this version a try
and let me know if it behaves the same way for you.

Internal Status set to 'Waiting on Customer'
Status set to: Waiting on Client

This event sent from IssueTracker by gcase 
 issue 265078
Comment 3 Gary Case 2009-05-12 17:28:28 EDT
It looks like it's partially solved. The PROFILER test is gone, but VIDEO and CDROM are still present on domU.
Comment 6 Rob Landry 2009-06-10 14:42:23 EDT
Closing per the above comment and any remaining changes will happen in 485837.

*** This bug has been marked as a duplicate of bug 485837 ***

Note You need to log in before you can comment on or make changes to this bug.