Bug 484983 - Clicking on a Logical Volume in disk druid edits the Volume Group
Clicking on a Logical Volume in disk druid edits the Volume Group
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
:
Depends On:
Blocks: AnacondaUI
  Show dependency treegraph
 
Reported: 2009-02-10 18:02 EST by Matthew Booth
Modified: 2009-10-02 04:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-02 04:44:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2009-02-10 18:02:57 EST
Description of problem:
This is a usability issue stemming from the separate handling of LVM volumes in disk druid. If you double click an LV in the bottom pane, instead of editing the LV as you might expect, you are instead presented with a new window displaying the volume group. In order to actually edit the LV you clicked on, you need to find it again and click edit.

Given that LVM is the default in Fedora, it should really be a first-class citizen in disk druid. There should be no separate window for editing logical volumes.

Version-Release number of selected component (if applicable):
anaconda-11.5.0.12-1

How reproducible:
Always

Steps to Reproduce:
1. Double click on an LV in disk druid
  
Actual results:
User is displayed options to edit the volume group.

Expected results:
User is displayed options to edit the logical volume they clicked on.

Additional info:
Comment 1 Joel Andres Granados 2009-04-08 08:40:05 EDT
If we don't have a separate window for each LV the thing would be a big huge mess because we would have to list  all the LVs in the VG.  I don't like the idea of a template that gets filled each time you choose an LV either as it does the same as the pop up window.  With the pop up window having the extra characteristic that it draws attention to the user to the new thing that appeared in the screen.
Comment 2 Bug Zapper 2009-06-09 07:15:26 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Joel Andres Granados 2009-09-08 09:31:46 EDT
This is more like rawhide.
Additionally, I't will not be present in f12.
Comment 4 Joel Andres Granados 2009-09-17 05:22:56 EDT
Matthew Booth:

Somthing I have been working on http://jgranado.fedorapeople.org/anaconda/ui/videos/direct_lv_edit.  It should make its way to f13.
Comment 5 Joel Andres Granados 2009-10-02 04:44:05 EDT
It in rawhide.  It will be present in anaconda-12.33 and over.

Note You need to log in before you can comment on or make changes to this bug.