Bug 484989 - find-provides has a bug which causes python tracebacks with yum repositories
find-provides has a bug which causes python tracebacks with yum repositories
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-10 18:48 EST by Karsten Hopp
Modified: 2009-02-11 10:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-11 10:20:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SRPM file which demonstrates the problem (2.25 KB, application/x-rpm)
2009-02-10 18:48 EST, Karsten Hopp
no flags Details

  None (edit)
Description Karsten Hopp 2009-02-10 18:48:04 EST
Created attachment 331500 [details]
SRPM file which demonstrates the problem

Description of problem:
find-provides doesn't handle quoted versions in pkgconfig properly.

Version-Release number of selected component (if applicable):
rpm-build-4.6.0-2.fc11.i386
redhat-rpm-config-9.0.3-3.fc10.noarch

How reproducible:
always

Steps to Reproduce:
1. build attached srpm
2. add resulting rpm to a repository and enable it
3. run createrepo on that repository
4. yum list

Actual results:
glib errors about 'a bug in someone's code'
python traceback with 'TypeError: Parsing primary.xml error: attributes construct error'

Expected results:
normal 'yum list' output

Additional info:
The problem is the parsing of the "Version:" line in the attached pkgconfig file.
Comment 1 Jindrich Novy 2009-02-11 06:50:20 EST
Just out of curiosity, is the quoted Version in .pc allowed by pkg-config?
Comment 2 Karsten Hopp 2009-02-11 07:44:18 EST
pkg-config seems to handle it without problems and I couldn't find anything in
the man and info pages about quotes, so it looks like quotes are allowed.
Comment 3 Jindrich Novy 2009-02-11 10:20:49 EST
Sorry, I think that allowing quoted Version would allow characters like spaces, etc. to be present in the version name what is weird and dangerous.

To allow this it needs reimplementation of the whole argv-like parser of the helper script output in rpm just because of a possibility that space will occur in the Version name (as demonstrated in your bug description). I'm not sure it has any practical sense.

Please reopen if you have different opinion or you have a case where the quoted version is unavoidable.

Note You need to log in before you can comment on or make changes to this bug.